Need testers for updated Enphase Envoy sensor

I’m in the process of updating the current Enphase Envoy sensor and am in need of testers.

The main change is to optimize how the sensor is retrieving the inverter data. With the current sensor some have seen timeouts (inverter data not updating) occurring. Usually on the older Enphase Envoy hardware and/or when there are a fair number of inverters connected to the solar system.

All that is needed is HA 0.110.0+.

Replace the homeassistant/components/enphase_envoy/sensor.py with this version and restart HomeAssistant.

I have also added more debug statements as well, so if you have problems with this version of the sensor enable debug logging using for example:

logger:
  default: info
  logs:
    homeassistant.components.enphase_envoy: debug

in your configuration.yaml

Are there instructions written for a 5 year old anywhere? I’d love to test but seem to be too stupid to follow the directions?

@kysdaddy My instructions are a bit vague if you are starting from scratch or do not know where to look.

I’ll try to give the steps I take in my production environment. Just be aware some file paths may be different due to system differences. I’m running HA 0.113.x in a docker environment.

  • Open an ssh/terminal/command line session to your Home Assistant server
  • Run the command
find / | grep enphase
  • You’ll get some output but look for the one that contains
homeassistant/components/enphase_envoy
  • Change to that directory, in my case I run:
cd /usr/src/homeassistant/homeassistant/components/enphase_envoy
  • Then run the below command to remove the sensor that came with Home Assistant
rm sensor.py
  • Then run the below command to retrieve the updated sensor file:
wget https://raw.githubusercontent.com/gtdiehl/core/http_api_call/homeassistant/components/enphase_envoy/sensor.py
  • Restart Home Assistant. I do that through the web interface. Click on the Configuration icon on the left-hand side, click on Server Controls and click on Restart under Server management
  • Once Home Assistant restarts you will be running with the updated Enphase Envoy sensor.
  • Now if you have problems and need to debug the sensor, that is when you should edit your configuration.yaml file to include
logger:
  default: info
  logs:
    homeassistant.components.enphase_envoy: debug

If you have any questions let me know and I’ll try and help

Thanks!

Thank you, that helped immensely. However this is what I found in the logs

Suggestions?

Chas

@kysdaddy I see this error when the IP address is wrong for the envoy device.

What does your configuration.yaml look like?

Here is an example:

sensor:
  - platform: enphase_envoy
    ip_address: 1.1.1.1
    monitored_conditions:
      - production
      - daily_production
      - seven_days_production
      - lifetime_production
      - inverters

Check that you can open a web browser to the IP address you configured.

That is the same except the actual IP in my config.yaml.
I do not get a response when I try to access the configured IP with a browser. I am connected to my wifi, I use Unifi ap’s I have a WLAN set up specifically for Solar and there is only one client connected to it.
But I continue to get the same error.

image
Chas

The server machine running Home Assistant needs network access to the Enphase Envoy. Not sure what your physical network looks like, but you’ll need to get both your networks to ‘talk’ with each other.

os there anything that needs to be done to the envoy system? The wlan is withing the same ip range, the guest controls are turned off. If I log a laptop or a phone into that wifi, it can reach the rest of my network but still gets "this site cant be reached when trying to access the envoy.

Oh ok that’s good it’s one network. When your laptop is logged into the original WiFi can you ping the envoy device? From the terminal/command line run ping x.x.x.x replace x with the envoy up address

What type of Envoy do you have? Model and Firmware?

No i can not ping the envoy, although when logged into the Solar wlan on my laptop I can ping other machines in my system but the envoy is unreachable no matter which wlan I am connected to.
Here is the information taken from my https://enlighten.enphaseenergy.com/ web portal

image

Thank you again for this help
Chas

How are you getting the IP address of the Envoy device? Is it from Unifi Controller software?

You can try and open a web browser to http://envoy.local rather than the IP address

http://envoy.local doesn’t work either.

I have the IP off my client list in Unifi, when I set this all up, the envoy was/is the only thing that logs into the Solar ssid. My unifi still sees that device as active. Oddly enough the ip scanner that I use does not see the device. But none of the unidentified devices located by the scanner have HTTP access either.