Need to do a fresh installation of Z-Wave

I have an installation which works as one would hope. Z-Wave, MQTT for Tasmota devices, MySensors for sensors and actuators. This is HAOS running in Virtual Box on a linux machine.

It’s an actual refurbished PC I got for under $100 on Amazon (Core i5-4570 3.2GHz 8GB 500GB DVDRW) (Recommend $10 2yr warrantee extension) because RPi’s are selling for a ridiculous price.

Now I’m trying to replicate that system. (export HAOS to a .ova, import on target machine) The Tasmota and MySensors was seamless. The Z-Wave is going to have to be a fresh start. I used the painful process (simplicity studio, tip, you must get account and log in) of resetting the ZST 10 700. I removed the Z-Wave integration, the Z-Wave JS add-on.

I plug in my ZST 10 700 which, to the linux system, is /dev/ttyUSB0. The virtual box sees my Z-Wave stick settings under USB,

When I attempt install the integration with add-on checked, I come to the page that Enter the Z-Wave JS add-on configuration which has the note The add-on will generate security keys if those fields are left empty. and next to USB Device Path nothing

Clicking on [submit] I get the error Not all required fields are filled in.

Remember, the OS, Virtual Box, HAOS are all working on another system. I have tried three settings the USB type in the settings of the Virtual box. I do not have access to the other system.

Any thoughts?


As it turns out, the virtual machine was not sharing the new Z-Wave ZST 10. It was looking to share the ZST 10 that had the id of the other machine, which, of course was not there.

What I did was I pulled out the ZST 10, shutdown HAOS (which stops the running VM) went to configuration of the HOAS VM, USB section and deleted the existing ZST 10 entry.

To check, I clicked on the [+] on the right side to ensure that there was no ZST10 there. (I may have closed the virtual box program, then restarted it at this point)

Then I plugged in the ZST10 and clicked on the [+] again and selected the ZST.

Then I started the VM and the HAOS seems to see the ZST10 now.

Next step is to connect a Z-Wave device