Negative values for individual devices - Energy dashboard

Hi all,

I’m facing an odd problem.
When adding some entities to the “individal devices” on the energy dashboard the graph goes negative

While the entity itself has a positive values
Screenshot 2021-08-09 153723

Anyone an idea what would be causing this?

PS: those are entities that have been modified in the “Customize” section to add the measurement state, last_reset and changed the power state to energy

I am also getting this but with the sensors from my TPLink HS110 smart plugs.

For HS110 when you add devices to individual devices, add total Consumption not Daily which reset every day and will give you negative value; watch there are 2 consumptiun for HS110, you need to add total.


Had a similar issue with a ZooZ ZEN25, rediscovering it addressed my problem. Have you tried a rediscovery? I know the chance of that fixing it is slim but it is quick to do if you have not already done it.

Good luck,

I took the suggestion from Alex and it seemed that the AC’s had a yearly overview as well.
So modified that with the necessary states and that seemed to work.
But thanks for the suggestion!

Thanks Alex, that suggestion has solved my problem.


Hi, I have a Tuya smart plug with I run with the Tuya local integration. I want to be able to add it as Individual device how do you change / modify the customize so it will show up in the device drop downlist. ?
I also only have.
switch.office_power.attributes.current which is in ‘mA’ and
switch.office_power.attributes.current_consumption which is in W
as far as I can read here I would have to create some total power consumption entity measured in kWh. Do anyone have an idea what I would need to create in configuration.yaml for it to work for Tuya or point me in some general guide. :slight_smile:

This is what I have currently to create 2 entities for my existing cards.

  - platform: template
        value_template: >-
          {{ states.switch.office_power.attributes.current }}
          unit_of_measurement: 'mA'
        value_template: >-
          {{ states.switch.office_power.attributes.current_consumption }}
          unit_of_measurement: 'W'


Hi. I’m having a problem where my gauges read back to front. Swapping the mins and max just breaks the gauge. Any ideas?

The gauge in question:
Screenshot 2023-08-19 130329

and the code looks like this:

type: gauge
entity: sensor.power_load_fronius_power_flow_0_10_0_0_225
name: Load
needle: true
unit: Watt
  green: -500
  yellow: -3000
  red: -8000
min: -8000
max: -1