NEO (Tuya) Zigbee Siren (and temp + humidity)

Tags: #<Tag:0x00007fc3eb157a00> #<Tag:0x00007fc3eb157910>

I am trying to get my Neo CoolCam siren with temp and humidity sensor to work under HA. It’s this one: Tuya siren

I am using the HA virtual machine with supervisor version 2020.12.6 and hardware OS version Home Assistant OS 5.8.

The Z2M version I am using is 1.16.2.2.

What I have done so far:
I have spoken with Ilya from Z2M to get the siren supported. He was great and added support right away. So all the “exposes” are now available. When I go to the Z2M web interface I can set the temp/humidity thresholds, melody, and the alarm itself. It is now supported in the normal production build of z2m.

I was hoping that that means it would also be available in HA, but that doesn’t seem to be the case.
What I have now in HA:

Name:
Temperature & humidity sensor and alarm (NAS-AB02B0)

Entities:

So all the entities are available, but they are not editable or actionable.
EG: I cannot set the siren to “ON” or set the alarm volume to “LOW”.

How can I get the inputs to be available in HA?

I have also found the thread below, but that doesn’t seem to explain it either. Or I am simply not getting it. Note: the one below is a WiFi siren, mine is Zigbee.

Anyone who can help with this? Or at least with the principle of getting this new hardware exposed properly in HA?

I did the work for Z2M, would be nice to get the last step done so I can actually sound the siren from within HA :slight_smile:

Is it that hard to get something to be supported in HA?
I must be missing something. There’s loads that work with HA, this can’t be that different?

Any help?

I have the same issue ! ho the zigbee !!!

Works fine here, I just added it to my zigbee2mqtt (1.17.0) network and all entities became avail in HA right away.

Maybe exclude it (through the zigbee2mqtt frontend) and include it again?

Hi

Did you have a lot of messages into Z2M logs about this device? It send me one message every second or two seconds :/.

I don’t know why so often I have messages from it

Thank you

I have a similar issue with HA. Not just for this device, but it often does not report all the values shown in zigbee2mqtt.
The only work around I have found is to keep deleting and re-adding the device till it works…

Is there a way to force HAS to get the values available on the device?

I think i have the same issue. I can see humidity and temperature but i can not turn on the siren. I get error turn_on - Service not found. I can test siren in z2m interface and that is all.

How can i turn on the siren?

1 Like

Hi Guys,

I have this siren

I used below code in switch section in my config.

Worked like a charm.

  - platform: mqtt
    name: Siren
    state_topic: "zigbee2mqtt/FRIENDLY_NAME"
    command_topic: "zigbee2mqtt/FRIENDLY_NAME/set"
    value_template: '{{ value_json.alarm }}'  
    payload_on: '{"alarm":"true"}'
    payload_off: '{"alarm":"false"}'
    state_on: "ON"
    state_off: "OFF"
    optimistic: false
    retain: false
    qos: 0

Hello, I have bought that siren, I have it integrated in HA with zigbee2mqtt 1.18.2-1 and its script does not sound the alarm, the truth is that I am already desperate I think I will use it on paper and buy another because I do not see a solution I have been involved for days and I can’t find a solution to make it sound thanks

You do realize that without providing any info, you cannot be helped with this issue?

For me it is working…

1 Like

this is my configuration.yaml and it does not work I do not know if I will have something wrong but it does not work, my version of zigbee2mqtt is 1.18

switch: 
  - platform: mqtt
    name: alarma_neo
    state_topic: "zigbee2mqtt/0x804b50fffe04846d"
    command_topic: "zigbee2mqtt/0x804b50fffe04846d/set"
    value_template: '{{ value_json.alarm }}'  
    payload_on: '{"alarm":"true"}'
    payload_off: '{"alarm":"false"}'
    state_on: "ON"
    state_off: "OFF"
    optimistic: false
    retain: false
    qos: 0

Question then is if mqtt is working/setup right in Home Assistant, and/or if 0x804b50fffe04846d is the correct topic

Do you have anything else running on mqtt / zigbee2mqtt?

If mqtt and zigbee2mqtt are directly installed in HA and HA is installed in raspberry pi 4 with docker on they should. And before I can not know if it worked in previous versions because I have bought everything recently and I have always installed the newest versions.
I have an aqra zigbee door sensor working properly

Hello,
I am using zingbee2mqtt v1.18.3-1 on Home Assistant 2021.5.0 running on Raspberry pi4 with CONBEE II. I joined successfully the NAS-AB02B0 but I have the following issues:

  1. I do not see any values for temperature, humidity etc neither in zigbee2mqtt device nor in Home Assistant
  2. I am unable to activate the alarm

I can set values to several entities through mqtt publish commands (seeing the proper logs)

Debug Received MQTT message on 'zigbee2mqtt/01_Alarm1/set' with data '{"melody":10}'
Debug Publishing 'set' 'melody' to '01_Alarm1

Tried to remove and join the device again , but I still receive the same results.
Any help would be appreciated.

Did you ever get sorted with the siren kaltsask?
I’m in exactly the same position

Hi Graham.
The issue is not fixed yet.
There is an open issue on github

1 Like

Hey guys,

Having a strange issue with this after not using it for a while.

If I turn on the alarm, it plays twice and then shuts itself off.

Anyone seeing something similar?

Thanks :slight_smile:

I have exactly the same situation here.

New to Home Assistant and Z2M, but have lots of other devices/sensors running without problems.

I have the V3 Version, too.