Nest Camera

Nest camera does not seem to be working.
Currently on 0.34.4

I followed the steps outlined here and was able to enter in the pin. However, when i go to my frontend it shows error loading image. My logs have the following:

16-12-07 11:05:20 aiohttp.web: Error handling request
Traceback (most recent call last):
File “/var/opt/homeassistant/deps/aiohttp/”, line 265, in start
yield from self.handle_request(message, payload)
File “/var/opt/homeassistant/deps/aiohttp/”, line 96, in handle_request
resp = yield from handler(request)
File “/usr/lib/python3.4/asyncio/”, line 143, in coro
res = yield from res
File “/usr/lib/python3.4/asyncio/”, line 143, in coro
res = yield from res
File “/usr/local/lib/python3.4/dist-packages/homeassistant/components/http/”, line 403, in handle
result = yield from result
File “/usr/local/lib/python3.4/dist-packages/homeassistant/components/camera/”, line 186, in get
response = yield from self.handle(request, camera)
File “/usr/local/lib/python3.4/dist-packages/homeassistant/components/camera/”, line 204, in handle
image = yield from camera.async_camera_image()
File “/usr/local/lib/python3.4/dist-packages/homeassistant/components/camera/”, line 91, in async_camera_image
None, self.camera_image)
File “/usr/lib/python3.4/asyncio/”, line 388, in iter
yield self # This tells Task to wait for completion.
File “/usr/lib/python3.4/asyncio/”, line 286, in _wakeup
value = future.result()
File “/usr/lib/python3.4/asyncio/”, line 277, in result
raise self._exception
File “/usr/lib/python3.4/concurrent/futures/”, line 54, in run
result = self.fn(*self.args, **self.kwargs)
File “/usr/local/lib/python3.4/dist-packages/homeassistant/components/camera/”, line 98, in camera_image
url = self.device.snapshot_url
File “/var/opt/homeassistant/deps/nest/”, line 1250, in snapshot_url
if self._device[‘snapshot_url’] != SIMULATOR_SNAPSHOT_URL:
KeyError: ‘snapshot_url’

I had the same problem and it was because I checked “Camera” and not “Camera + Images” in permissions. I had to uncheck “Camera” and then I was able to check “Camera + Images.”


I changed my permissions, but i’m still getting the same error. I restarted HA. Do I need to delete the nest.yaml file that HA created?

I removed the nest.yaml file and forced a reconfiguration and entered in a new pin. Works now! Thanks bmorton!

1 Like

Cool! Yeah, I did the same thing, but I think you can also click the “Allow” button on the notification you get in the Nest app to allow the additional permissions.

hi question . working for me now… but its a still image right? not streaming ?

yes mine is a still image as well

even still image .changing pic n very bad… where is the config to change the refresh
best idea , but still streaming not working like simple IP cam

What do you mean by forced a reconfiguration? I’m stuck in a similar boat it looks like and can’t get the configuration card on the gui to comeback so I can enter the pin. What steps did you take?

All I did was delete your nest.yaml file and restart HA. It will ask you to configure again.

1 Like

THat worked for me. I went back to nest developers and remove camera permissions. Added camera+image. Back to HASS. Deleted nest.conf. Restart HASS. Configured nest with new PIN. Restart. All good.


This fixed my problem kevince52. They should modify the instructions for the component section to be specific about this.

Agree- Same issue here, due to following instructions. I then change permissions , then restart de HA and thats it… is working. but still image though…

I, too, am only getting still image. I have the pre-Nest acquisition version of the DropCam.

Did you ever get streaming working?