Nest Cameras Suddenly Not Working


Have two nest cameras (doorbell and home hub max) setup with Home Assistant using setup on the integration page. Suddenly they have stopped working and I am getting the following error in the logs:

Source: components/stream/
Integration: Stream (documentation, issues)
First occurred: 00:32:22 (59 occurrences)
Last logged: 00:56:49

Error opening stream rtsps:// (long link here I assume to camera)

I can still see the cameras functioning normally in the Nest app. I did move Home Assistant over to a new RP4 and SSD using a backup yesterday, though the cameras have been working perfectly fine since then until just now.
Tried a reboot of Home Assistant and that hasn’t helped. Any help on this would be appreciated. If you need any further info please let me know. Cheers :slight_smile:

EDIT: The one thing I have also changed recently is the lovelace card to camera_view: live. Tried changing back but still getting nothing.

1 Like

I’m having the same issue. Started earlier today and I haven’t changed anything in my setup. Rebooting did not work either. I’m using an HA Blue.

Same for me. I hope it’s a Nest problem and it will fix as soon as possible. I use with an external url and also with a share link, both don’t work.

Same here. It seems like there is an outage of some sort.

Hier ook thermostaat werkt wel maar camera’s niet

I think they might have changed the API - i can still get to it through the Nest app. Video stream through VLC no longer works (broke frigate as well) , and you can access the stream through their HTML link if you set the stream to public.

Occurred about 1 PM MDT today. Next step is to look through the google developer portal to see if they changed the API

Bij mij werkt het weer :slight_smile:

Just came back up for me 12h later.

Thanks for the replies. Went to bed and woke up to find it’s all back up too so must have been an outage as suggested.

Now it works