Nest component not quite right

What’s up with the nest component lately? Mine has been like this for a while. Even downgrading my HA docker to < 0.65.6 and it still is screwed up. I’m guessing something in their API changed if multiple versions of HA are exhibiting similar behavior.

What appears the be the issue?

  • “Heat null - null °F” instead of showing the current heat set point
  • multiple target temperatures at the bottom
    - the 64°F is the current set point, but no idea what the other two do
  • the history graph has additional lines/fill
    - the red line is current temperature then that graph is filled with the green, and the blue line is the current set point
  • where it shows the two “°F” with up and down arrows, I can supposedly set the temperature set point to 1°F?

the component used to have a single temperature set point, show the mode and fan operation, and the graph used to show the set point and current temperature.

Oh I see, Could it be that somehow your nest is now setup / enables for both heating and cooling?
Check your Nest’s settings and disable HVAC if you have no air conditioning device linked to it

I have full HVAC. I haven’t changed a single setting since setting up the component. the nest is in heat mode, which the component shows correctly. I know it showed properly in 0.63.X or lower, maybe 0.62.X I can’t remember exactly when it changed.

hum that’s interesting…
I just checked and I think you may be right:

I’m still on 0.64 and my Nest and I only have heating
I don’t have the null values, but do have the dual empty temp… Guess there was a change that I’ve not tracked…

by the way, 0.66.1 has this:

Update frontend to fix climate and chart issues (@NovapaX & @c727)

What version are you currently on?

I am on 0.66.1 and did not notice any change.

On the mobile app and mobile safari I don’t get the “null - null”, but everything else still applies. Also I experience these issues on Safari on macOS and Google Chrome on W10.

I believe the two settings on the bottom are for auto (heat-cool) and eco modes.

just as an FYI, I’m on chrome, just updated to 0.66.1 and it looks ok:

However I’m now home, my previous screenshot was taken from work so maybe there are blocked ports or other security features where you are that might meddle about?

nope, no blocked ports where I am. I installed google chrome on my Mac at home and I see all the same issues except the “null - null”. I also don’t understand why the graph has the fill under the lines. When I hover over the graph, the component has 3 data points for just 2 values (current temperature and current set point)? Also, the operation text (heat, cool, auto, off), and fan mode (on, auto) is all lower case, not uppercase like your screenshot.

I don’t know if I said it before, but I’m running the docker container on Synology. I’ve restarted the container, cleared it and downloaded a fresh copy, and still have these issues.

Yep, you’re right those are for auto mode (and I believe eco mode). but they still appear in normal heat/cool mode even though no value appears there.

my 0.66 version is running on docker on ubuntu. not sure what’s wrong…
just tested IE, Edge and FireFox, no issue with any of them either…

cleared cache in both browsers, rebooted computer, still shows up. could this be a front end javascript version issues? I’m using es5 according to the info/log page from the frontend. my config is forcing es5 instead of using auto. I believe it’s to get the HA app and safari on an old iPad running 9.3.5 to work.

this is my info bit:

Home Assistant

Path to configuration.yaml: /config

Developed by a bunch of awesome people.

Published under the Apache 2.0 license
Source: server — frontend-ui

Built using Python 3, Polymer 2.6.0, Icons by Google and

Frontend JavaScript version: latest

and I only have this in my config:


For what it’s worth - I’m seeing the exact same issue with the thermostat control via the Wink component.
Heat null - null °F
Currently: 69 °F

This started a week ago, probably at the same time I updated to Hassio v66.0.

Just letting you all know this issue isn’t limited to the Nest thermostat component. I will now update to 66.1 and update this post.

UPDATE: yep, 66.1 fixed this issue. Even says right there in the release notes that “climate and chart issues” were addressed. Just be sure to clear cache and restart browser after the update.

yep done all of that. the “null - null” has been fixed but the climate component is still a little messed up visually as I described above. clearing cache, restarting, etc didn’t change anything for me.

my config has:

  javascript_version: es5

I’ll try forcing it in the url or switching to auto/latest in my config later and report back.

Ah - see what you mean. I was only focused on the compact component showing the values properly. I too have the dual blank temp settings when the component is expanded.