Nest integration, 2 locations, one not working

I have Home assistant running with the nest integration in location A, and had set up another instance of home assistant at another location B. I added the nest integration at B with a new google nest project and device access. This seemed to work for a few weeks, then I saw that the nest integration at location B needed to be reconfigured. I’ve gone thru the reconfigure screens for location B, and I can see that it is now using the device access credentials from location A.

I’ve disabled the nest device in Home Assistant location B, and then attempted to delete the credentials (Settings → Devices… → Integrations → 3dots → Application credentials. I select and try to delete the credentials but it tells me that the credentials are in use in a nest device. I also tried disabling the nest thermostats in location A, but still get the error that the credentials are in use. There does not seem to be a mechanism to remove the nest device.

What am I missing?