Nest integration causing lockups and restarts of HA

So today I added Nest integration, well I tried to.

I followed the documentation, got it all setup, got my secrets and api stuff.

Added the integration it got me to log into Google, added all my options and it then takes you back to HA and then nothing, it either locks up, or it says open webpage to login again.

Connection keeps getting lost to HA when I’m trying to add Nest.

A few times requiring me to unplug and replug my odroid N2+ as it just starts giving out a 504 gateway time out error.

Something is pretty buggy with Nest integration, and it was only this I was adding today.

I cant get the logs as it locks up and then I’m unable to access HA at all.

Can anyone try to point me in the right direction? All it does is lockup HA or cause it to freak out doing anything. I did see errors in the logs where API was getting stuck and reset, will try see if I can find it again.


21-10-22 20:46:36 ERROR (MainThread) [supervisor.homeassistant.api] Error on call 21-10-22 20:46:36 WARNING (MainThread) [supervisor.misc.tasks] Watchdog miss API response from Home Assistant 21-10-22 20:49:07 ERROR (MainThread) [supervisor.homeassistant.api] Error on call 21-10-22 20:49:07 ERROR (MainThread) [supervisor.misc.tasks] Watchdog found a problem with Home Assistant API! 21-10-22 20:49:07 INFO (SyncWorker_4) [supervisor.docker.interface] Restarting Package odroid-n2-homeassistant · GitHub

Ive tried in incognito mode and cleared all browser cookies and cache.

Tried Brave and Safari… It just will not work and keeps crashing HA with the above API issue.

Can anyone help me with this?

I spun up a fresh VM with no config except:

# HAProxy Tursted Proxy
  use_x_forwarded_for: true

Added my Nest config.

I run HAproxy on OPNsense.
All my other services are fine. My HA instance gets full SSL cert and I can log in remotely and from anywhere.

Everytime I follow the guide and setup a new Nest integration and add it to HA, it loads the Google login page, I get redirected to HA and then it dies. Redirection never completes and HA comes up with the same warnings as above. It takes like 15mins and then comes back to life.

Please can anyone help me where I’m going wrong?

FYI the IP in the first logs are not mine… No idea where it comes from but its always the same.

Can anyone help?

Hi, i’ll follow up with you on the issue you filed.