Nest Integration Error - 403 Access Denied

I am getting an error after successfully completing the steps for the Nest integration. The integration card shows a 403 error. I wanted to know if anyone received this error after completing all the steps successfully and how you resolved it.

ok so I fixed the error, I went back through the steps in the documentation and found that somehow my API was disabled. If you are getting this error, go to Google Cloud Platform and make sure that the API is enabled.


when I first went back to this part of the setup, the MANAGE button said ENABLE.

Not sure if I missed that step or if it was on Google’s end.


Thank you for posting this update, glad you got it working.

I’d still like to reply to this resolution, because for me it was something else.

Within the project (go to the Google developer console) and from the menu “OAuth consent screen” in “APIs & Services” I created my Google user as a test user. This allows this user (you) to access the project.

You can also set the project (same OAuth consent screen) as public, but that option opens up the project for all Google users (but it also works) :slight_smile: