Nest Integration, how to Authorize new devices?


Last month I added the Nest integrations following all the instructions and steps for the SDM API and it works well but when I got forwarded to the URL for the the authorization step I only authorized the devices I wanted to show up in Home Assistant (Thermostat and only 2 of my the cameras).

I just bought and setup a new camera and it is not showing up in Home Assistant even after reloading the integration and restarting the server. I assume it is because I need to re-authorize and add permissions to the new camera, but, I am only forwarded to this URL during the setup of the Integration.

Is there any way to re-authorize and change the permissions to the devices without deleting and re-adding the integration? I looked everywhere in the Cloud Console and also I tried to build this URL myself but I’m probably doing something wrong because I get an error at the end after adding the permission to the new device (domain and code masked):

Missing code or state parameter in


The way you do this is typically delete the integration then re-add it, and it will ask you to authorize all the devices again, including the new device, then it works. Does that work for you?

From the description it sounds like you somehow were reauthorizing and it didn’t work, but just wanted to confirm if you got there via deleting it first.

Thanks, actually what I did worked, after I used the URL I built above and authorizing the additional devices I just had to restart Home Assistant and the new devices showed up… sorry I forgot to update this thread.

Would be nice if there was a button in the integration to re-authorize so you can add / remove permissions / devices as needed without having to delete the integration.

1 Like

Yeah, agreed. I am adding a Configure button in Add Nest OptionsFlow flow for adjusting permissions for fetching media for events by allenporter · Pull Request #61527 · home-assistant/core · GitHub and am trying to see if its possible to open the “reauth” flow from there. Haven’t seen how to do it yet but i’ll ask the other core devs.

1 Like

I’m trying to do the same thing. How did you build the URL? and where did you apply it? TIA!

I found a simpler way to do this, and updated the troubleshooting instructions. Checkout the first link here: Nest - Home Assistant


Thank you so much. This is great.

thanks that worked, update quickly and easily my new nest devices. Thank you