Nest integration presents blank dialog

I’ve followed all of the steps to set up a Nest integration using the new web authentication method, but after entering my Cloud console project ID and Device access project ID and clicking submit HA just presents a blank dialog:

There are no associated errors in my browser console or the HA logs. This is HA 2022.7.3.

There’s a bit of a backstory: Nest was working great using the desktop auth method, but I tried to upgrade upon being notified about the deprecation. During the upgrade I got about a thousand different errors and ended up removing the integration entirely. Now I can’t add the integration again.

Without even any errors in the logs, what can I do to debug this? Is it possible that HA is holding on to some data from the old integration that I’d need to purge? There’s certainly nothing in the yml files but I don’t know what could be in the db.

I am in the exact same boat. I have been trying for the biggest part of the morning to get this to work again with no luck.

Home Assistant 2022.7.4
Supervisor 2022.07.0
Operating System 8.2
Frontend 20220707.0

Browser cache issue? ctrl-shift-R?

Not a browser cache issue, I’ve tried clearing local storage for my personal HA domain,,, and

How about enabling the debug logs on the nest integration docs? That may give more error details we can look into.

Also see With 2022.7.0 my NEST integration fails - #18 by fribse which sounds similar.

I enabled debug logs but I see nothing interesting in the logs. Certainly no errors. I’m hesitant to post the full logs in a public forum.

Today the error is different, now I get redirected to a google site with the following error:

Can’t link to Home Assistant
Please contact Home Assistant if the issue persists

This does look very similar to With 2022.7.0 my NEST integration fails - #18 by fribse . But I already deleted my old credentials from configuration.yaml. It’s like they are still being cached somewhere internally.

Seems like With 2022.7.0 my NEST integration fails - #19 by danep has more traction so I might move discussion there.

I finally figured this out, see my solution here: With 2022.7.0 my NEST integration fails - #20 by danep