Nest Integration stuck on "Next Steps...", then empty Error

Hi, I just completed all the steps for Nest integration, authorized everything paid the fees and so on. Right after you authorize homeassistant to access your Nest devices, right after you “link your account”, you get to a simple dialog box with a spinner that says “Loading nest step for Nest”. After about 1 minute, this box just stops spinning and shows “Error”, but no error message.

Does anyone have any idea what is going on?

Thank you.

I don’t have a for sure answer, but have a couple ideas of things to check:

  • You may want to double check the url at is correctly pointed at your home assistant instance.
  • Check out the logs and see if there are any error messages

What’s the base of the URL that shows the Error? Just curious if this is from your home assistant instance or browser error and its hard to tell from the description.

  • So I updated the link: it was pointing to home assistant.local however mine is home-assistant.local, so that is changed. Thanks for pointing that out. However, no change in the behaviour.
  • The error in the end just shows “error” and an OK button. No text.

If I tail the home-assistant.log file in /config, I do not see anything new when I try to add Nest again. Am I looking in the right log file?


I solved the problem. You must disable IPv6 using nmcli.

nmcli con modify "Wired connection 1" ipv6.method disabled

Replace “Wired connection 1” with the connection name in

nmcli con show

Once you do that, everything worked. I did haver to go an enable the Cloud Pub/Sub API in the Google cloud console for the project.

All is good now.

Tha nks

Hi @stephb9959 - I have this exact problem but am quite new to Home Assistant! Would you mind explaining in more detail the process for disabling the IPv6? I don’t understand where I need to go to apply these changes.

Thanks @stephb9959 Ipv6 was definetly the issue.

@joshua.brett You can disable Ipv6 in the console by going to settings->System->Network->[ETH0/WLAN0/etc…]->IPv6->Disable

Hope that helps

Wow, finally I’ve gotten to the root cause of all the Nest integration issues – I tried to move a HomeAssistant instance running via the Docker install on a RPi4 to a HAOS VM running on Proxmox, and although initially things seemed to work, more and more things started failing, and Nest integration seemed to be related to many of them.

I bet the issues I had with time sync at boot were also IPv6 related :confused:

So, I guess the big takeaway is don’t let your friends install HomeAssistant with IPv6 enabled.

Thanks so much for this!