Nest integration woes

Yeah I can’t find anything. So let me ask, you can’t control the nest from HA, but does HA pick up the state changes if you manually adjust the nest?

Firstly, Thank you for following up. Basically what has been working all along and continues to is HA is able to read all sensors that were created linked to Nest, however I’ve never been able to write/set temperature of the Nest using HA ( I can however using the Nest App).

Based on what you mentioned regarding read/write authorization, I logged into my Nest developer account to establish if I could change the ‘write’ permissions. I got the following response.

This is supposedly where the write authorization is established. As you can see the message ‘Opps! We’ve encountered and error. Please try again.’ comes up time and time again…

Any thoughts or work arounds you can suggest would be greatly appreciated.

Ahh ok, yeah so back before Nest shut down the developer stuff (Early 2019) you would have had to go in and set all the perms to read/write. That Oops! message basically is what everyone gets now while trying to access that site. There’s no way to actually change any of that anymore so you may be stuck with just reading the values unfortunately.

And if you look at this link: you’ll see step #7 back then was to check all the permissions on the developer site and set Read/Write if applicable.

All of that unfortunately isn’t possible anymore.

I hope this helps more.

1 Like

Unfortunately what you state is what I feared… So frustrating that I had a chance and blew it ahgrrr!!!. Thanks anyway Jb, appreciate your response.

Thank you sir I appreciate the info. I’m not sure I have a valid back-up only my configuration.yaml. I will see if I happen to have a back-up from when it worked but not holding my breathe. Thanks again appreciate the support!

Thank YOU.
It was a smack in the face, after buying into the NABU CASA thing, to have Google take away my access to my Nest thermostat.

Do you know EXACTLY what pulled the code from the .storage\core.config_entries?

Appreciate your input…


I’ve never had the Nest integration setup in HA, but I did have an old Homebridge setup laying around. I took my old home bridge config:

  "platform": "Nest",
  "token": "c.WOUuldNtYouLikeToKnow...thisISactuallyREALLYlongString",
  "clientId": "19028301-fake-uuid-goes-here90900",
  "clientSecret": "aLsoAFAkeSecretValue",
  "code": "NICETRY"

and applied it to the sample data above to /root/config/.storage/core.config_entries

  "connection_class": "cloud_push",
  "data": {
    "impl_domain": "nest",
    "tokens": {
      "access_token": "c.WOUuldNtYouLikeToKnow...thisISactuallyREALLYlongString",
      "expires_in": 315360000
  "domain": "nest",
  "entry_id": "NICETRY",
  "source": "import",
  "title": "Nest (via configuration.yaml)",
  "version": 1

coupled with my configuration.yaml:

  client_id: 19028301-fake-uuid-goes-here90900
  client_secret: aLsoAFAkeSecretValue

… voila! it works. Hope this helps someone until the whole mess with google gets worked out

Thanks for this. Luckily I have my old unsuppored “hassio on ubuntu” instance still up whilst I am migrating to hassos.

Life saver almost 3 years later. Thank You!

FYI for anyone else finding this from Google the core.config_entries file is under .storage in the config folder.