Nest integration woes

I’m aware of Google’s recent changes to works with Nest and I think I might be hosed but here’s to one last ditch effort to get my integration working again.

I’ve had my two Nest thermostats working with HA for nearly two years. I recently started having trouble with my entities showing up in Lovelace so I removed the integration with the intent of adding it back. When I go into Integrations and click Configure next to the Nest component I get the usual dialog that prompts for authorizing your account. When I click on that and am taken to Nest I get the error “Oops! We’ve encountered an error. Please try again.”

I checked my Nest list of approved integrations and noticed that Hassio showed up 4 times. This is probably due to the fact that I’ve lost and rebuilt my Hassio system at least that many times. My thought was maybe I had maxed out my available integrations so I attempted to remove the first of the four on my list. By removing that entry however, all of the four were removed.

Is there any hope of adding Nest integration back to Hassio at this point?

I think I’ve literally done the same thing just now.

Had a previous config saved, imported that, started getting the new messages without really readying, clicking through and migrated my account to Google Works.

Check out this:

I’m getting the same “Oops! We’ve encountered an error. Please try again" on a new HA install on my Pi4 and I haven’t migrated my Nest account. I just used the existing client_id: & client_secret: as I have in the past but doesn’t seem to be working anymore. :pensive:

Same here, getting the Oops! We’ve encountered an error. Please try again. Using my same client id and secret I have used in the past. I also have not migrated my nest account.

I thought we were supposed to be fine as long as we already had the dev account with the keys!!!

This sucks!!

I was able to get my previous nest integration working again.
Luckily I had an old HASS instance that was still connected with the same keys. I copied the nest entry from core.config_entries from my old instance to my new one and I was connected again.


One of the lucky few in these times of woe. I tip my hat to thee.

I did try again to add it thru the integration, still give me the oops :frowning:

That is not in line with their press releases saying if we like our integration we can keep our integration.

I am happy I still have it (for now) with HA, but I have purchased one of the brilliant light switches and was planning/hoping to use it there, not so much.

Huge thank you to @stogs for the tip-off on restoring a backup version of my Nest access token from .storage/core.config_entries. :+1:

I rebuilt my HA environment today, thinking that being grandfathered into the Nest developer access would be sufficient, and was dismayed to deadend at the same error message others here have seen…

Oops! We’ve encounterd an error. Please try again.

(Same circumstances: Have not migrated my Nest account, still using same client ID & secret from past 1.5 years)

Lessons learned:

  • Backups were worth it
  • I need a new thermostat

This just totally saved me… thankful for my backups as well… perfect use of the community… found the file, copied the JSON over to my new config.

1 Like

Does this still work? I got it working but a few days later it stopped again

Wow!! you just saved my bacon… I have been struggling with this for days after having to do a recovery after my SSB on RPi3b+ crashed. Thank you very much it works now!!!

Wow - I just rebuilt my instance, and Nest was the only thing that didn’t work right - you saved me! I was ready to order a different thermostat!! Thank you, sir!!!

1 Like

Spot on! Luckily had a backup of my old config. Copying the entry from core.config_entries worked a treat! Thanks

Thanks folks, I arrived here with the same issue and a three year old backup has saved the day. Copying the entry from core.config_entries worked perfectly! Thanks

a nest integration through the google API has been managed with a bit of a hack.

could similar methods be used for Home Assistant ?

1 Like

This restored my Nest connection as well, but seems to have nuked my HACS config? I had to create a new API token and reintegrate the integration?

I have my old keys from a previous HASSIO build how are you all getting this to work? I have added the keys to the config but when trying to integrate I get the opps message as well.

Just curious if anyone can help me to understand the methods you are using to integrate your nest devices? Keep in mind I’m fairly new to hassio.

Joe, I noticed no-one responded yet and I wanted to let you know I just did this today for my nest thermostat and here is how. You’ll need a working backup of your config when it worked. Then locate the file .storage\core.config_entries in the backup and find the section like below:

                "connection_class": "cloud_push",
                "data": {
                    "impl_domain": "nest",
                    "tokens": {
                        "access_token": "*****",
                        "expires_in": 315360000
                "domain": "nest",
                "entry_id": "*****",
                "source": "import",
                "title": "Nest (via configuration.yaml)",
                "version": 1

Cut and paste it into your fresh install into the same file. Take note where the ***** are as it will be random and unique to your account. Also when pasting into the new file make sure the formatting/spacing is correct.

Then I simply pasted my nest: section back into my configuration.yaml, did a quick config check, and restarted. I was right back in business. If you go to the integrations section you’ll notice the Nest section will be back auto-magically.

I’m not a home assistant pro but I hope this helps clarify it.

1 Like

Jb, I have been able to get HA to read the current status of sensors, etc of my Nest thermostat by using the method you outline using the tokens I was able to recover.
However, I have not been able to modify any of the operating modes/temperature setting or any of the settable parameters, even using ‘Developer Tools’ -> Services-> climate.set_temperature service.

I get the following error, Any suggestions?:

An error occurred while setting temperature: No write permission(s) for field(s): target_temperature_low_f,target_temperature_high_f 11:59:41 AM – nest (ERROR)

Bastero, I apologize up front but I’m not sure what this could be. Personally I didn’t have any problems like this and I can control mine just like before but I did find a old 2017 post on git that someone was getting similar write permissions that was solved by enabling the +rw on the nest developer account. I assume you had all that working before of course… I’m going to double check my config and see if there was something else maybe I missed and I’ll get back.