Nest Mini TTS not working, but fine with Home mini

For months, I’ve had a Google Home Mini that I used with Home Assistant for TTS notifications. Always worked, never an issue. Recently, I’ve added a Nest Mini (basically a Google Home Mini v2), but I can’t get the TTS to work on that one.

I can see that HA creates the .mp3 file in the right directory, the media_content_id that is sent to the devices is also correct (I can play the mp3 file in my browser at the given URL,, the device chimes, but the message is not played.

I know al my general HTTP settings (like base_url) in HA are working because TTS works fine on the older device. Does anyone know how I can fix this?

I fixed it. The problem was that the Nest mini uses the Google DNS ( / by default, which means it tries to access my HA instance by the external IP. My router doesn’t support NAT loopback, so that doesn’t work. The rest of my home network uses the internal Pihole DNS which resolves the HA hostname to a local (192.168.x.x) IP address.

I blocked access to the Google DNS servers on the router, causing the Nest mini to use the local DNS server as a fallback. This is a difference between the Google Home mini and the Nest mini, apparently.

I have only a modem and a router. Should I install pihole on my Home Assistant and block the dns? Or is pihole not required?

If you’re in the same boat as I was, you already have a local DNS running (maybe Pi-hole) because you want your hostname (probably to resolve internally to a different IP than externally. You want to make sure the the Nest Mini can’t reach Google’s DNS (block and in the router) and that it falls back to your local DNS. You can’t use Pi-hole to do this because it does not involve name resolution.

I think that is my issue. I dont have Pi-Hole DNS or a local DNS. All I have is Acher c1200 Router and a modem from my (dutch) internet provider. Besides that I am using DNSmasq to have my HA accessable from out and inside with the duckdns url. Quit complicated

Try this to block Google’s DNS IP’s:

Do it for both the and addresses.

I will give it a try. Fingers crossed!
Update: No succes I will lose my entire connection some how.

You do need a working DNS somewhere. You can either try setting up Pi-hole or use your ISP’s default servers.

Check out 3 solutions to Nest Mini TTS not working on this thread

Hi there,

can anyone explain how to block DNS resp. I am using a Fritzbox 7590 as router.

Thanks Chris