Nest Thermostat Configuration Issue

I am having trouble getting elements to show up after using the Nest configuration.

configuration.yaml shows (with appropriate values from Nest development):

      client_id: 1324567890
      client_secret: ABCDEFGHIJK
      platform: nest

After entering the id and secret in configuration.yaml, restarting, and entering the validation string from Nest I am only seeing the following:

No other entities are present. I have reconfigured multiple times and enable all options on Nest development to no avail.

Did you specify those services in your configurations?

Paste the following in the templates section of HA and see what you get.
{{ states.climate.living_room.attributes }}

Mine looks like below:

Sorry, replace living_room with your thermostat name.

I tried it out and still nothing is coming through. I do have a couple thermostats attached to my account which is causing me to wonder if that is having an impact on the situation.

The names were weird for my setup. Here are what mine are called in my installation. I have two controlling two separate units for the home.

# Climate
    name: Climate
      - climate.master_bedroom_master_bedroom_nest
      - climate.hallway_hallway_nest

Did you setup nest via your config, or the integration option whitin HA?

Where did the following come from?

Nest Configuration

I placed the client_id and client_secret in my config, restarted HA, clicked the new integration for nest in HA and added the authorization from Nest. After saving I was given just the two entities I have in the previously attached image.

climate: platform: nest was added later to attempt to give me some more information.

IDK, try deleting the config, reboot, then setup via the config / integrations option

I’m having the same issue, tried to configure via the integration tab and manually using the configuration.yaml file with the same result. Do you have to add the climate: section in the config?

Was this ever solved? I have the exact same issue. I get a few options, but no climate.x to read temperature etc. I will try to set-up the config from scratch again and post an update if successful.