Nest thermostat official integration error Check configuration

Hello to all
I have set up the Nest integration for the thermostat which works perfectly.
but when I have to update HASSIO I run version test with “Check Home Assistant configuration”
where the following error comes out
if I delete the settings in config.yaml and do the check again, everything is ok.
But all the versions I have to enter # and after the update remove them.
Does it just happen to me?

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] udev.sh: executing... 
[cont-init.d] udev.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
[21:29:52] INFO: Don't worry, this temporary installation is not overwriting your current one.
[21:29:52] INFO: Installing Home Assistant: latest...
[21:29:52] INFO: Please be patient, this might take a few minutes...
[21:31:22] INFO: Installed Home Assistant 2021.9.7
[21:31:22] INFO: Making a copy of your configuration for checking...
[21:31:23] INFO: Checking your configuration against this version...
[21:33:30] ERROR: The configuration check did not pass!
[21:33:30] ERROR: See the output below for more details.
Testing configuration at /tmp/config
Fatal error while loading config: The 'google-auth<2.0dev,>=1.25.0' distribution was not found and is required by google-api-core
Failed config
  General Errors: 
    - The 'google-auth<2.0dev,>=1.25.0' distribution was not found and is required by google-api-core

Successful config (partial)
[21:33:30] INFO: The full output has been written to /share/check_config.txt
[cont-finish.d] executing container finish scripts...
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.
[s6-finish] sending all processes the KILL signal and exiting.

Did you solved this issue?

If this was solved please let me know. I have this same issues. Rather then delete the setting in config.yaml I just comment them out. Then after I do the upgrades I un-comment them and everything is happy once again.

What did you comment out? Then I will try it tomorrow also