Nest Thermostat Precision in celcius

I see this kind of query has been posted a number of times but I’m still struggling.

I have integrated Nest thermostats into my HA. It seems that because they’re set to celcius and the API reports back actual accurate figures rather than what is displayed on the thermostat display (in increments of 0.5), there is a mismatch between the thermostat and HA. Currently, my thermostat is showing 22 deg yet HA is reporting 22.2 as the current temperature.

Whilst this isn’t the end of the world, it’s a bit confusing plus the graphs appear to show target temperatures havn’t been reached but the heat being turned off e.g. in the following example. The thermostat target temp is set to 21. Yet HA reports this as 21.1 and when the actual tempeature hits 21, HA reports this as 20.8. Consesquently, the orange block stops even though the current and target temp lines aren’t at the same level.

I’ve tried setting the precision for the Climate to 0.5 to no avail. I’ve also used tempates with the following code:

- platform: template
      friendly_name: "Current Temperature"
      unit_of_measurement: °C
      value_template: >
        {{ (((state_attr('', 'current_temperature') | float) * 2) | round ) / 2 }}

This creates new entities but won’t update the actual values I’m seeing in my themostat card or the graphing data. And whilst this almost always reports the figure aligned with what is on the thermostat’s display, it’s not fool-proof and will sometimes be 0.5 out.

Any help gratefully receveied!

1 Like

Did you ever find a solution for this? I have the samen “issue” with the offset :frowning:

1 Like

Hey I think I have solved this. If you go to developer tools then to states and select the temperature entity you can change the current state to match what your nest reads and that appears to fix the issue.

Edit: this appears to only work until the physical thermostat has been changed:( hopefully someone smarter has a solution.

1 Like