Nest thermostats are not responsive

I’ve gone through the procedure to setup a product, set permissions for “other” and then added this to my config

  client_id: XXX
  client_secret: YYY

When I restart, I see my two thermostats represented by a bunch of icons (temp, humidity, etc) but all of them are not reporting any values. they are also named None. I authorized HA with the popup code as well. I’m also not seeing the thermostats in the dashboard. I rebuild my HA server and this was working before with the same “product”. Any ideas on how to troubleshoot this?

I found this in the log:

> Log Details (ERROR)
> Sat Jul 14 2018 22:52:52 GMT-0400 (Eastern Daylight Time)
> nest: Error on device update!
> Traceback (most recent call last):
>   File "/usr/lib/python3.6/site-packages/homeassistant/helpers/", line 248, in _async_add_entity
>     await entity.async_device_update(warning=False)
>   File "/usr/lib/python3.6/site-packages/homeassistant/helpers/", line 319, in async_device_update
>     yield from self.hass.async_add_job(self.update)
>   File "/usr/lib/python3.6/concurrent/futures/", line 56, in run
>     result = self.fn(*self.args, **self.kwargs)
>   File "/usr/lib/python3.6/site-packages/homeassistant/components/climate/", line 274, in update
>     self._temperature = self.device.temperature
>   File "/usr/lib/python3.6/site-packages/nest/", line 529, in temperature
>     return self._device.get(self._temp_key('ambient_temperature'))
>   File "/usr/lib/python3.6/site-packages/nest/", line 504, in _temp_key
>     return "%s_%s" % (key, self.temperature_scale.lower())
> AttributeError: 'NoneType' object has no attribute 'lower'

I bet your developer account permission is not set correctly, you need all read permission, and write permission for the part you want to control. Can you post the screenshot of your permission settings page?

Holy cow! This forum software is amazing. Ctrl-V to paste an image. I love it!

And why not the overview too:

As I said, if you want HA to control your Thermostats, you need give us your Thermostats permission at the top of the page, Thermostats read/write

The instructions specifically say you shouldn’t do that.

For permissions check every box and if it’s an option select the read/write option. Note: there are important permissions under the “Other Permissions” category. If you are only adding a thermostat, do not just select the permissions under “Thermostat”. You still need to check the boxes under “Other Permissions” in order to give you access to features like away mode, ETA, structure read/write, and postal code.

It said

do not just select

means you need select both permissions under “Thermostat” and “Other Permissions”

By the way, to make the change works, your need to reauthorize the changes through your nest app, and restart home-assistant

Ah, I saw messages in the iOS app. Somehow I got it working with just using the code.