Netatmo aborted error

Tags: #<Tag:0x00007f326c740810>

Hi everyone,

I have a Netatmo thermostat and it used to work great with Home Assistant. I moved a couple of months ago and I am now trying to set up my home assistant instance from scratch. So far everything is working, except the Netatmo integration for my thermostat.

In the configuration.yaml I have set up:

netatmo:
  client_id: !secret netatmo_client_id
  client_secret: !secret netatmo_client_secret

I checked, and the client id and secret are still correct.

Then, when I try to add the Netatmo component via the frontend, it just tells me ‘Aborted’, however there are no error logs in the log file and no other indication what is wrong.

I have tried taking the code away from the configuration.yaml, when I then try to add the integration, it does say that it needs the code in the config file to work…

What am I doing wrong?

I’m running Home Assistant 0.115.6.

Netatmo have been having issues the last few days, people have been reporting things back to normal.

But could be that there are still issues.

What device are you using to do the configuration?

I’m not sure that I understand what you are asking, but I usually do the frontend configuration via Chrome on Mac OSX and the backend is done on VSCode also via Mac OSX. Is that what you where asking?

Yes, exactly that. If you don’t have cameras you can actually drop the yaml configuration altogether and use the HA Cloud Link.

Please also add debug logging for the Netatmo integration to get some insights on what is going wrong.

So, I have tried using Firefox, but that didn’t change anything.

I do have camera’s, and I’m not using the HA Cloud…

For the logging, there is nothing in the log file from netatmo, I added homeassistant.components.netatmo: debug
and
netatmo: debug
to the logger…

I am using HA Cloud and I am having the same issues as you describe. I foolishly removed the integration and tried to re-add, but no luck. Neither via yaml (“Abort” error as you describe) nor via Cloud (it adds the integration, but no devices found and error messages in the log). Seems Netatmo is having issues at the moment.

Same Issue here, I just received my replacement netatmo presence (my old one had issues) I gave it the same name hoping that nohting would change in HA, but it didn’t work so I removed the integration to add it again.
When I add it, I get a choice between “configuration.yaml” & “home assistant cloud”, when I choose configuration.yaml, I immediately get “Aborted”, and if I choose the cloud, it works but I get no device in it.

Thanks, that is valuable information. The cameras are not expected to work with the cloud link (yet).

Oh, you mean Netatmo camera’s? no, I don’t have those…

However, with the update to 0.116, it does seem to work now

That probably has nothing to do with the release but the netatmo backend seems to be still flaky.

OK I guess I figured it out…
Since the last release of HA, I have a little more info on what is causing the “Aborted”, and the message says " No URL Available ", after a quick search I found that this is caused by the fact that I was now using DuckDns and HTTPS access to my HA.
The solution was to reach the HA via the local IP instead of DuckDns address to install the Netatmo integration.

It was not easy as that for me, I had to turn off the “HTTPS” just for the time to do it, but I’m not sure it was necessary.

Finally everything is working as before.

I hope this helps the community.

1 Like

Have you checked your external and internal url?