Netatmo Cameras no longer working in 0.118.5

I recently upgraded from 0.118.3 to 0.118.5 and my netatmo cameras (outdoor and presence) are no longer working.

I’ve tried removing and re adding the integration, and downgrading back to 0.118.3 (and removing / re adding again) but still getting the same problem.

The web hook is registered fine and sending camera events

Error in the log below:

2020-12-06 09:45:53 ERROR (MainThread) [] Error while setting up netatmo platform for camera
Traceback (most recent call last):
File “/usr/src/homeassistant/homeassistant/helpers/”, line 199, in _async_setup_platform
await asyncio.shield(task)
File “/usr/src/homeassistant/homeassistant/components/netatmo/”, line 95, in async_setup_entry
async_add_entities(await get_entities(), True)
File “/usr/src/homeassistant/homeassistant/components/netatmo/”, line 54, in get_entities
await data_handler.register_data_class(
File “/usr/src/homeassistant/homeassistant/components/netatmo/”, line 149, in register_data_class
await self.async_fetch_data(
File “/usr/src/homeassistant/homeassistant/components/netatmo/”, line 117, in async_fetch_data[data_class_entry] = await self.hass.async_add_executor_job(
File “/usr/local/lib/python3.8/concurrent/futures/”, line 57, in run
result = self.fn(*self.args, **self.kwargs)
File “/usr/local/lib/python3.8/site-packages/pyatmo/”, line 91, in init
File “/usr/local/lib/python3.8/site-packages/pyatmo/”, line 166, in update_camera_urls
self.cameras[home_id][camera_id][“local_url”] = check_url(
File “/usr/local/lib/python3.8/site-packages/pyatmo/”, line 162, in check_url
return resp.get(“local_url”)
AttributeError: ‘NoneType’ object has no attribute ‘get’

Hello! After updating to 0.118.5 I also lost my outdoor camera/presence.
I didn’t change anything and didn’t really bother. After a few restarts (tweaking automations and config) suddenly the camera was working again.

Not a big help, but it fixed itself or something :wink:

I installed everything 10 days ago and I never saw my Netatmo Cameras in HA… I hope they are going to fix it soon…

Thanks - I’ve tried removing and adding a few times, also tried with a fresh Netatmo app & totally unable to add anything now (also have weather station)

Finally sorted - a restart of all the cameras did the trick.

1 Like

Can I use the Netatmo integration from the UI to access the camera entities? I just added a Netatmo camera but its not showing up.

I’m in the same situation. I have four cameras and I cannot see them in Netatmo Integration. However I can see all other Netatmo products… :sob:

In order to get cameras and especially webhook events working propperly (for now) you are required I strongly recommend to set up an individual dev account and use that in your config. There are currently issues with webhook events when used with the HA cloud link.

Hi, I thought this config (you linked) is mandatory to have the cams in?

Actually, you are 100% correct. I have a prototype running here to get rid of the necessity of an individual dev account, but due to before mentioned issues with the webhook events this has not gone live yet.

Good catch @thechem, thanks for correcting me.

Happy to help! Is there a possible to test the prototype?

If you can/want to live without webhook events, yes. Just drop me a PM or ping me on Discord.

Is the indoor siren supported as well?

No, unfortunately there is no real API for it. You may receive webhook events though.