Netatmo component throws error

Since a few days I get an error on the netatmoe component which I use for my netatmo thermostat. On the start of homeassistant I get the error :
2017-07-29 17:09:10 ERROR (MainThread) [] Error while setting up platform netatmo Traceback (most recent call last): File “/srv/homeassistant/lib/python3.4/site-packages/homeassistant/helpers/”, line 164, in _async_setup_platform SLOW_SETUP_MAX_WAIT, loop=self.hass.loop) File “/usr/lib/python3.4/asyncio/”, line 372, in wait_for return fut.result() File “/usr/lib/python3.4/asyncio/”, line 277, in result raise self._exception File “/usr/lib/python3.4/concurrent/futures/”, line 54, in run result = self.fn(*self.args, **self.kwargs) File “/srv/homeassistant/lib/python3.4/site-packages/homeassistant/components/camera/”, line 42, in setup_platform for camera_name in data.get_camera_names(): File “/srv/homeassistant/lib/python3.4/site-packages/homeassistant/components/”, line 84, in get_camera_names self.update() File “/srv/homeassistant/lib/python3.4/site-packages/homeassistant/util/”, line 303, in wrapper result = method(*args, **kwargs) File “/srv/homeassistant/lib/python3.4/site-packages/homeassistant/components/”, line 115, in update self.camera_data = lnetatmo.CameraData(self.auth, size=100) File “/home/homeassistant/.homeassistant/deps/smart_home/”, line 78, in init self.default_camera = list(self.cameras[self.default_home].values())[0] IndexError: list index out of range

I even setup hass from scratch today from a new hassbian image but keep getting the same error.

anybody any ideas ?

Solved it for now by disabling auto discovery for netatmo and added the Relay and Thermostat manually. Now the errors during auto discovery are gone and only the thermostat is displayed