Netatmo events never fired - Are Netatmo webhooks working?

after wasting so much time setting up Netatmo integration in Home Assistant, this post is my last ditch effort before giving up. :sob:

My domotic system is all branded “Biticino with Netatmo” devices, for a total of about 50 devices as follows:

  • 1 DIN gateway [FC80GT]
  • many dimmer switches [N4411C]
  • many shutter controls [N4027C]
  • 4 connected modules for socket [N4531C]
  • many lighting micro module [3584C]
  • 1 wireless motion sensor [3585C]
  • 1 Wireless Night&Day scenario control [N4574CW]
  • 1 Wireless Home&Away scenario control [N4570CW]
  • 1 DIN smart relay for light control [FC80RC]
  • 2 Smarter with Netatmo thermostats [XW8002]

This is the context:

  • Home Assistant Core on docker via Container Station in a QNAP nas (tried stable version 2022.11.4 and also latest 2022.12.7).
  • Caddy reverse proxy on docker via Container Station in the QNAP nas, config file:
(https_header) {
  header {
    Strict-Transport-Security "max-age=31536000; includeSubdomains"
    X-XSS-Protection "1; mode=block"
    X-Content-Type-Options "nosniff"
    X-Frame-Options "SAMEORIGIN"
    Referrer-Policy "same-origin"
} { 
  import https_header
  • Port 443 open and forwarded to (NB: port 80 can’t be used for custom mapping on my router because is reserved).

  • Set external URI in HA to

  • Set http block in configuration.yaml:

  use_x_forwarded_for: true
  • HA already reachable from remote via

  • Registered app in dev Netatmo portal (never got banned, I check every time), used Client ID and Secret to store credential in HA and added integration Netatmo using credentials (no Home Assistant Cloud).

  • Netatmo webhook successfully registered:

2022-12-21 18:54:00.586 INFO (MainThread) [homeassistant.components.netatmo] Register Netatmo webhook: ``

2022-12-21 18:54:00.827 DEBUG (MainThread) [homeassistant.components.netatmo.webhook] Got webhook data: {'user_id': 'yyyyyyyyyyyy', 'user': {'id': 'yyyyyyyyyyyy', 'email': '[email protected]'}, 'push_type': 'webhook_activation'}

2022-12-21 18:54:00.827 DEBUG (MainThread) [homeassistant.components.netatmo.webhook] None: {'user_id': 'yyyyyyyyyyyy', 'user': {'id': 'yyyyyyyyyyyy', 'email': '[email protected]'}, 'push_type': 'webhook_activation'}

2022-12-21 18:54:00.830 INFO (MainThread) [homeassistant.components.netatmo.data_handler] Netatmo webhook successfully registered
  • Adding a dimmer switch to my Home, turn on the light (and the light already turn on, so integration works correctly) but the icon lights up after 5 minutes.

  • Listening to netatmo_event shows nothing and nothing!

  • In order to check if webhooks arrive to HA I tried to configure an automation with a webhook trigger to turn on the same light. Sending the POST request in POSTMAN turns on the light, so webhook are correctly received by HA.

The question is simple: are Netatmo webhooks working or am I wasting my time? Do they work for my devices (i.e. dimmer switches N4411C and power switches N4531C)?

Thank you very much folks.

Update: tried the custom components Netatmo [BETA] by @cgtobi and nothing changes. No Netatmo webhook arrives to HA to update the light status.

Here you can download a video to see what happens:

First you can see the light “Luce madia” is off in Bticino app HOME+CONTROL. Then I turn it on in HA touching the switch. The switch turns on but after two seconds it turns off again. At the end you can see the light “Luce madia” is already on in HOME+CONTROL but not on HA. If I had waited 5 minutes on the HA screen you would have seen the switch light up.

Obviously, this makes impossible to use the integration in HA.


There are not Web hook events for devices other than original Netatmo devices.

Unfortunately this is expected behaviour for BTicino and Legrand devices. We are in contact with Legrand/Netatmo to improve the situation.

Hello, I have the same problem. I would appreciate it if the states of the devices are updated instantly

Yes, understandable. Unfortunately we are at the mercy of Legrand/Netatmo.

Thanks for your reply @cgtobi

This is very disappointing for Bticino/Legrand/Netatmo. They already did stop supporting IFTTT since the beginning of this year. Without webhook HA Netatmo integration is totally unuseful. I can’t power on and off a simple light, but I have to wait 5 minutes to update the light status and turn it off. And this is not the worst thing: there’s no way to create smart automations for my 54 devices. Really disappointing! If I had knew it before I would never choose Bticino/Legrand devices. I will consider to sell them on aftermarket and migrate to full supported devices like Shelly.

As I already mentioned, we are in contact with Legrand/Netatmo to improve this.

1 Like

Is this the same problem I’m facing here?
Netatmo shedule state is very slow to change (webhook seems ok) - Configuration - Home Assistant Community (

Was this solved by Legrand/Netatmo? I’m using Bticino devices and it seems that I don’t receive any webhook events.

Webhook events are provided only for a few selected devices so far.

Hello there, I think we have the same issue on that topic, and we identified a few devices that are OK, and others that are not.

@cgtobi is there any way we can help with that issue?