Netatmo Home Coach not detected

Followed the instructuons regarding to how to integrate Netatmo, however there’s no result. I don’t understand either why should I add an api key to the config as the netatmo online service doesn’t offer any possibility to add Netatmo Home Coach as a device so I assume their online service tracks only weather stations.

Is there anyone out there who has no station, but only the Home Coach and was able to get this work with HA?

Noone got Netatmo Home Coach working with HA?

Been trying to get the home coach working for the last couple months without any luck. Have you tried a firmware upgrade of coach?

Did you get it working? I have not succeeded with mine :frowning:

I have this PR that fixes the problem that it will not discover Home Coach if you already have a Weather Station. Hopefully it will get merged soon.

As I see it, our problem is the complete opposite. Home coach cannot be added if so not have a station. There’s no way to get to the web interface and obtain a token, if you only have a home coach. When trying, you just get a prompt to add a station.

So you are not able to obtain an api and secret key through

The Netatmo online service is for sure tracking the data from HomeCoach.

You can have an API from the dev.netatmo website. The fact the cloud does not includes home coach is another matter.

However I can’t add home coach at all (despite having API secret which I tested and is working): auto discovery fails to add anything and manually : impossible to add any module in the sensor config … since home coach does not have any modules.

Anyone ?

Hi all,

unfortunately, I’m stuck on this also. Having Home Coach App on iOS, it’s connected with my mail address and receives data from my home coach every n minutes. When I’m logged in on netatmo dot com, I have „no devices connected“ and my home coach does not show up any more (just a pop-up that allows me to add anything except a Home Coach). As this is the way suggested in component documentation, things seem to have changed – I’m using this device for months now and I’m pretty sure I could see it’s data on netatmo dot com (probably before Netatmo belonged to Legrand??).

Autodiscovery indeed fails. When deactivating the app on, at least I get an error message in home-assistant.log:

Feb 19 22:36:47 leinen hass[7039]: #033[31m2019-02-19 22:36:47 ERROR (MainThread) [homeassistant.setup] Error during setup of component netatmo#033[0m                                                │
Fe│Feb 19 22:36:47 leinen hass[7039]: Traceback (most recent call last):                                                                                                                                 │
Fe│Feb 19 22:36:47 leinen hass[7039]:   File "/srv/homeassistant/lib/python3.5/site-packages/homeassistant/", line 148, in _async_setup_component                                                │
Fe│Feb 19 22:36:47 leinen hass[7039]:     component.setup, hass, processed_config)  # type: ignore                                                                                                       │
Fe│Feb 19 22:36:47 leinen hass[7039]:   File "/usr/lib/python3.5/asyncio/", line 380, in __iter__                                                                                              │
Fe│Feb 19 22:36:47 leinen hass[7039]:     yield self  # This tells Task to wait for completion.                                                                                                          │
Fe│Feb 19 22:36:47 leinen hass[7039]:   File "/usr/lib/python3.5/asyncio/", line 304, in _wakeup                                                                                                 │
Fe│Feb 19 22:36:47 leinen hass[7039]:     future.result()                                                                                                                                                │
00│Feb 19 22:36:47 leinen hass[7039]:   File "/usr/lib/python3.5/asyncio/", line 293, in result                                                                                                │52
20│Feb 19 22:36:47 leinen hass[7039]:     raise self._exception                                                                                                                                          │
ta│Feb 19 22:36:47 leinen hass[7039]:   File "/usr/lib/python3.5/concurrent/futures/", line 55, in run                                                                                          │
--│Feb 19 22:36:47 leinen hass[7039]:     result = self.fn(*self.args, **self.kwargs)                                                                                                                    │--
20│Feb 19 22:36:47 leinen hass[7039]:   File "/srv/homeassistant/lib/python3.5/site-packages/homeassistant/components/", line 53, in setup                                                     │
20│Feb 19 22:36:47 leinen hass[7039]:     'read_station read_camera access_camera '                                                                                                                      │
20│Feb 19 22:36:47 leinen hass[7039]:   File "/srv/homeassistant/lib/python3.5/site-packages/", line 74, in __init__                                                                            │
20│Feb 19 22:36:47 leinen hass[7039]:     self._accessToken = resp['access_token']                                                                                                                       │
20│Feb 19 22:36:47 leinen hass[7039]: TypeError: 'NoneType' object is not subscriptable#033[0m

When activating it again, I get… simply nothing in my logfiles (neither with homeassistant.components.netatmo: debug). But I realized that it seems to try read_station, read_camera and access_camera – I miss read_homecoach? Was it ever intended to work with Home Coach devices?

Any help would be appreciated as I am not a developer. If you need further information just ask. I’m running HA 0.87.1 on Hassbian.


The user in another posting is affected too. I’m not allowed to post so many links :roll_eyes:

After seeing it was mentioned in the docs for, I assumed it would work.

After reading this thread however, I now realize it does not work.

I’ll write this off as a bad purchase.

This is magically working for me after updating to the newest version!

My bad purchase was turned into a good purchase <3

I have the same issue with version 0.91.2. No magician helps me :frowning:

Did you do something to fix?

I configured the platforms sensor, binary_sensor and camera because I have a Netatmo welcome also.
Discovery is set to false.

Did you try just with discovery?

Done with and without discovery

Hm, the only things I have done to configure it is set up the Netatmo account as explained in the docs, and then I added this to my configuration.yaml

  api_key: !secret netatmo_secretapi
  secret_key: !secret netatmo_secretkey
  username: !secret email_primary
  password: !secret netatmo_password

  - platform: netatmo

Do you see all home coach?

Multiple you mean? I only have a Netatmo Home Coach, no other Netatmo devices.

I have 2 home coach and I see only one. Thank

First: You need to put the password between “” else you got an error, but after i tried it with my password as “password” within Quotes i got invalid config.