Netatmo in HA 0.105

This is exactly what I did - got blank page and then returned to HA and all was goo din the hood.

1 Like

Upgraded and now it’s not working, I renamed client_id and client_secret but still nothing

This caused my some serious issues, of course it’s not directly related, but as I mentioned above I want to restore to my backup.

So I flashed my sd card with the latest hassio image (done this process before several times and usually it works fine), installed samba to get my backup on the pi and restored (wipe & restore). I waited for over an hour but my ha doesn’t show up again.

SSH connection refused. It’s online because I can ping it but nothing else. Tried that twice.
I noticed that my database is pretty big (4GB). I’m running a pi4. Do I have to give it even more time? Any suggestions. I might have to open another topic for that. Maybe you can split that here @cgtobi ? Topic name could be: HA 0.105 restoring to 0.104.3 fails.

EDIT: Just now I tried ssh again and it is online again, I might give it more time. I will definitely switch to a nuc soon.

Ok, i got mine sorted, here’s how in case anyone is stuck. I commented out my entry in my configuration.yaml, restarted HA, added the integration and selected using configuration.yaml and it suceeded. then uncommented my configuration.yaml which worked on a restart

Have you removed the username and password from the configuration and have you tried to add it in integrations in the GUI?

Well, I am totally stuck trying to get my Netatmo Welcome working again. I have tried with my netatmo entry in configuration.yaml set to the three lines suggested (with my values inserted, of course), and with all the netatmo entry commented out. In both cases I can select Netatmo on the Integrations GUI. This takes me to the Netatmo site, I agree to HA access, and then - nothing! The HA GUI still displays the box asking me to OPEN WEBSITE. I have tried this with different browsers, but with the same outcome. Any suggestions?

1 Like

Hi all

are Netatmo Public Data sensors still available?

I have followed the new procedure to get Netatmo climate thermostat and it works, but I don’t see anymore those sensors.


PS: I’ve just seen that "Public weather sensors are removed and will be added back in a separate PR."

105 looks awesome but also have the netatmo problem - I am trying the same but don’t quite understand where you get the option to “select configuration.yaml”- When I go to the integration page and click +, I find the netamo integration and then it opens the oAuth page on Netatmo page where I get the Accept Loop problem.

Where do you select configuration,yaml option ?


I also get the page to authorize the third party application, wenn I press accept it closes the tab and reopens the same page again. Wenn I press authorize again, it gives me a 500 internal server error.

Same issue here with the oAuth autorization page on Netatmo. Tried creating new app with same result. On accept I get redirected and recieving an connection refused on my duckdns ssl exposed instance over port 9600. Base URL is set to the correct value, has been working for 2 years now without issue.
Also tried using the nabucase route, no luck either. Got in a loop there; after accepting page reloads after a couple of seconds.

Anybody else any pointers on where to look next?

UDPATE: it appeared there was still an older port in my baseurl (dev instance), updated that to the correct one. Also enabled popups because I saw something blocked after accepting. Result, same issue as @arjenvr , internal server error.

If you comment out all entries in your configuration.yaml and restart it is an option to select when adding the new integration before the Netatmo auth accept page, at least it was for me

We decided against putting this in the docs as it is mentioned in the breaking changes section in the release notes of 0.105. It should only be a onetime issue for people coming from earlier versions.

Is there a way on github to see older versions of the docs using github somehow? If there are changes like this in future it would help me work out what values are what in my configs.

Hello, can someone explain me what Configuration Flow Dialog means? I cannot find that buttom or specific action!
I tried to follow the steps but no netatmo integration is working. All entities are unavailable.

Go to the integrations page hit the + and select Netatmo. Then use the configuration.yaml option (not cloud/Nabu Casa for now). This should take you to a page from Netatmo to authorise your devices to be used.


Hello, a ok well that i did several times. But the netatmo authorization page remains in place even after 10 times clicking to Yes!

What is the solution to get my netatmo link back up and running please?

Change in configuration like this:
client_id: = api_key
client_secret: = secret_key

then reboot and it should work better with the linking.

Comment it out completely, restart, add the integration, then uncomment it and restart is the way I got it working

Where do you get api_key and the secret_key?
Sorry I’m new at this…

This is well documented here:

I did the same but when I try the integration, and select configuration.yaml, I select open website, it shows error invalid_client