Netatmo in HA 0.105

You need client_id and client_secret, as described in the documentation. But remove every other piece of netatmo related configuration.

Well, I tried AGAIN with the netatmo yaml lines in place. This time I was offered a choice of authentication method. That has never happened before. When I selected the yaml option, it went to the Netatmo site, I selected “Yes”, and it returned to Lovelace with the entity created. It has a different entity name from before, but I can live with that. I have no idea why I was given a choice this time, and never before. One thing - I don’t have Home Assistant Cloud enabled, and that was the other choice. Is that unusual? Could that explain the failures when I tried with the netatmo lines commented out in configuration.yaml?

The cloud link service is available for everyone even without subscription. As far as I recall.

What exactly went wrong in the first place I can only guess. Sorry if that isn’t satisfactory.

Hey. I have the same problem. Selected the yaml option. Netatmo authorization page remains in place even after clicking to Yes many times. I hope there are solution for it.

Update: upgrading to 105.2 did the trick for me. Guess something was wrong with the scope…
All good now.

The fix in 0.105.2 should only affect the the cloud linking service. So as long as you don’t have a camera that you wanna use in HA that should be fine now.

@PeterTje It was wrong in the sense that we are not “certified” by Netatmo and therefore not allowed to use a certain scope for security reasons.

Did you double check your yaml config? Did you run the config checks?

I will later today upgrade to 0.105.2 and try again. :grinning:

@cgtobi after upgrading to 105.2 my setup worked again . Thx!

1 Like

Any info on when public sensors will be available again? What is PR?

As soon as it has been reimplemented. PR stands for Pull Request. I can’t give a timeline.

Glad to hear that.

Hi Tobi, I did, this morning it turned out, for some reason this is not working for me using my iPad. I tried again using my Windows 10 / Chrome machine and it worked fine!

1 Like

Ok, good to know. Glad you got it working.

@cgtobi Okido :slight_smile:

Still not working in 0.105.2, still getting the 500 server error, server got itself into trouble.

I have an instance only accessible locally, no ssl, and tried with and without base_url set. I never get any options upon adding the integration, always just asks to open the website. The website open fine, I can grant rights, then it closes and reopens and pressing the button again gives the 500 error.

I also tried it from different browser, from mac osx and win10, and from an iphone. Always the same error. Does anyone have an idea what it is I’m overlooking?

After some more tries it suddenly connected!

1 Like

Did you restart HA in between? I think HA remembers which option you choose therefor you have to restart HA as far as I know to get to choose either configuration.yaml or cloud.

When you reimplement the public sensor, can you please add Mode = avg, max and min? (minimum has been missing!) :slight_smile:

1 Like

Hi, I have an issue with the new Netatmo-integration (0.105.2).

When I press the open website button I get to a web page displaying only:


Relevant parts of configuration.yaml:

  ssl_certificate: /config/cert.pem
  ssl_key: /config/key.pem
  base_url: https://[masked addr]:27544

  client_id: [from Netatmo connect]
  client_secret: [from Netatmo connect]
#   username: [old cfg]
#   password: [old cfg]

I see no relevant updates in the log.
I have also tried to regenerate the keys in netatmo connect, and have restarted home assistant many times.

Any ideas what to try next?