Netatmo integration can't be added

Tags: #<Tag:0x00007f3263f4e830>

I am having what may be a related problem. Cameras disappeared. However I can’t remove the integration as it doesn’t appear in the Configuration>Integrations page. This is true when I remove configuration.yaml netamo setup and reboot also. It is as if the integration wasn’t installed except If I try and add it I get an “Aborted Already configured message”. As a result I can’t add, remove, or modify the netatmo setup and it isn’t working?

Do you have any Netatmo related entries in the logs? If not, raise the log level for the Netatmo integration to debug and restart HA.

not sure how to raise log level since it doesn’t appear in my list of integrations under configuration?

# Example configuration.yaml entry
logger:
  logs:
    homeassistant.components.netatmo: debug

netatmo appears in log 65 times

Initially:

2020-10-19 19:06:58 DEBUG (MainThread) [homeassistant.setup] Dependency netatmo will wait for after dependencies ['media_source']

then:

2020-10-19 19:07:02 INFO (MainThread) [homeassistant.setup] Setting up netatmo
2020-10-19 19:07:02 INFO (MainThread) [homeassistant.setup] Setup of domain netatmo took 0.0 seconds

2020-10-19 19:07:02 DEBUG (MainThread) [homeassistant.core] Bus:Handling <Event component_loaded[L]: component=netatmo>

then entries like this:

`2020-10-19 19:07:05 DEBUG (MainThread) [homeassistant.components.websocket_api.http.connection.140365068420336] Sending {'id': 18, 'type': 'result', 'success': True, 'result': {'latitude': 35.674246, 'longitude': -105.927094, 'elevation': 7200, 'unit_system': {'length': 'mi', 'mass': 'lb', 'pressure': 'psi', 'temperature': '°F', 'volume': 'gal'}, 'location_name': 'Ranchitos', 'time_zone': 'America/Denver', 'components': {'zeroconf', 'person', 'sensor.synology_dsm', 'denonavr', 'sense', 'input_number', 'vacuum', 'binary_sensor.synology_dsm', 'camera', 'default_config', 'sensor.adguard', 'input_datetime', 'switch.adguard', 'image', 'mobile_app', 'recorder', 'binary_sensor.tesla', 'upnp', 'search', 'api', 'notify', 'fan', 'binary_sensor.sense', 'ipp', 'input_text', 'ssdp', 'lovelace', 'cloud', 'netatmo', 'binary_sensor.template', 'updater', 'fan.dyson', 'homekit', 'ffmpeg', 'auth', 'media_player.samsungtv', 'cast', 'scene.homeassistant', 'alarm_control_panel.envisalink', 'hacs', 'alarm_control_panel', 'switch.tesla', 'lock', 'weather.met', 'system_health', 'binary_sensor.updater', 'media_player.cast', 'sensor.hacs', 'config', 'media_player', 'adguard', 'alexa', 'group', 'notify.mobile_app', 'synology_dsm', 'media_player.roon', 'sensor.envisalink', 'media_source', 'persistent_notification', 'tts', 'climate', 'webhook', 'stream', 'met', 'weather', 'air_quality.dyson', 'device_tracker.tesla', 'heos', 'logger', 'sun', 'switch', 'climate.honeywell', 'envisalink', 'zone', 'air_quality', 'lock.tesla', 'scene', 'http', 'history', 'nut', 'binary_sensor', 'climate.tesla', 'remote_homeassistant', 'sensor.nut', 'tag', 'device_automation', 'climate.dyson', 'homeassistant', 'samsungtv', 'websocket_api', 'vacuum.dyson', 'frontend', 'sensor.ipp', 'automation', 'roon', 'logbook', 'google_domains', 'sensor', 'sensor.dyson', 'input_select', 'sensor.tesla', 'tesla', 'dyson', 'system_log', 'input_boolean', 'device_tracker', 'onboarding', 'binary_sensor.envisalink', 'sensor.sense', 'map', 'script'}, 'config_dir': '/config', 'whitelist_external_dirs': {'/config/www', '/media'}, 'allowlist_external_dirs': {'/config/www', '/media'}, 'allowlist_external_urls': set(), 'version': '0.116.4', 'config_source': 'yaml', 'safe_mode': False, 'state': 'NOT_RUNNING', 'external_url': 'https://private.domain.us:8123', 'internal_url': 'https://private.domain.us:8123'}}`

and this:

`[homeassistant.components.zeroconf] Discovered new device Netatmo Presence._hap._tcp.local. {'host': '192.168.86.52', 'port': 5001, 'hostname': 'localhost.local.', 'type': '_hap._tcp.local.', 'name': 'Netatmo Presence._hap._tcp.local.', 'properties': {'_raw': {'c#': b'7', 'ff': b'1', 'sf': b'0', 'pv': b'1.1', 'md': b'Presence', 'id': b'E9:3D:FA:3D:1A:94', 'na_tkn': b'3c19b2902fb8', 'ci': b'17', 's#': b'42439'}, 'c#': '7', 'ff': '1', 'sf': '0', 'pv': '1.1', 'md': 'Presence', 'id': 'E9:3D:FA:3D:1A:94', 'na_tkn': '3c19b2902fb8', 'ci': '17', 's#': '42439'}}`

nothing that looks like an error. However nothing from netatmo appears in Integrations, Device, or Entities

Did you actually add the integration? Does it show up in the integrations panel?

It does not show up in the Integrations panel but when I try and add it it says:

“Aborted
Already configured. Only a single configuration possible.”

it was previously working via yaml config - I think I may have had it running that way before the integrations panel add option came along. The cameras stopped working and that is what pointed me here.

Right, sorry, you already wrote that. Please check if netatmo is mentioned in your .storage/core.config_entries.

  {
                "entry_id": "831c582e63544f73afa052b38c155b16",
                "version": 1,
                "domain": "netatmo",
                "title": "Ignored",
                "data": {},
                "options": {},
                "system_options": {
                    "disable_new_entities": false
                },
                "source": "ignore",
                "connection_class": "cloud_poll",
                "unique_id": "netatmo"
            },

Ah, there we have it. You ignored it at some point.

Go to the integrations panel and click the three dots in the top right corner. Select “Show ignored integrations” and click “stop ignoring”.

1 Like

That was it, it didn’t appear once I stopped ignoring but I was able to add it and it is now working including cameras. Thanks!

1 Like