Netatmo integration, Presence camera not working

Tags: #<Tag:0x00007f739a6175c8>

i’m using cloud access

That’s probably your issue then as has been mentioned your meant to be using the configuration.yaml

1 Like

ah i see, that’s my bad, i’ll try that, thanks

1 Like

ok, i’ve changed it to configuration.yml but got the same result. only my weather related products are visible, none of my presence camera nor my welcome is shown

Sounds like your in a similar situation as me then. Do you also have the error while setting up netatmo platform for camera, in your logs, and a similar one for the lights? Looks like HA can see there are cameras there, but doesn’t integrate them.

There appear to be some server issues with netatmo at present, which may be related, but strange how both our weather stations are recognised.

Netatmo has sever issues. See this thread for further information.

Thanks Tobi, the cameras just came back of their own accord so was certainly Netatmo’s server issue, musty have been going on for a bit longer than they had acknowledged. Thanks for everything!

1 Like

Hi all,

I’m still having issues related to this. I tried @cgtobi script found here: https://gist.github.com/cgtobi/5601aa88efba2cce30a98aeae50582a2

To test wether the script is able to detect the Netatmo camera. The script locates all of my Netatmo units including the camera. Home assistant still doesn’t find the camera. I tried once again removing the integration, restarting the server and including again using configuration.yaml.
Still the same thing.

In the logs I get the following:

Logger: homeassistant.components.camera
Source: components/netatmo/data_handler.py:117
Integration: Kamera (documentation, issues)
First occurred: 20:42:57 (1 occurrences)
Last logged: 20:42:57

Error while setting up netatmo platform for camera
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/helpers/entity_platform.py", line 193, in _async_setup_platform
    await asyncio.shield(task)
  File "/usr/src/homeassistant/homeassistant/components/netatmo/camera.py", line 94, in async_setup_entry
    async_add_entities(await get_entities(), True)
  File "/usr/src/homeassistant/homeassistant/components/netatmo/camera.py", line 53, in get_entities
    await data_handler.register_data_class(
  File "/usr/src/homeassistant/homeassistant/components/netatmo/data_handler.py", line 149, in register_data_class
    await self.async_fetch_data(
  File "/usr/src/homeassistant/homeassistant/components/netatmo/data_handler.py", line 117, in async_fetch_data
    self.data[data_class_entry] = await self.hass.async_add_executor_job(
  File "/usr/local/lib/python3.8/concurrent/futures/thread.py", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/local/lib/python3.8/site-packages/pyatmo/camera.py", line 122, in __init__
    self.update_camera_urls(camera_id)
  File "/usr/local/lib/python3.8/site-packages/pyatmo/camera.py", line 179, in update_camera_urls
    self.cameras[home_id][camera_id]["local_url"] = check_url(
  File "/usr/local/lib/python3.8/site-packages/pyatmo/camera.py", line 175, in check_url
    return resp.get("local_url")
AttributeError: 'NoneType' object has no attribute 'get'

same error for me

10 posts were split to a new topic: Netatmo integration can’t be added

A post was merged into an existing topic: Netatmo integration can’t be added