Netatmo integration problem


I try to integrate my Netatmo presence camera but I always get the message:
'Missing code or state parameter in’

I tried all the procedures proposed in the similar topics but no success.
Qnap docker. HA Version: 0.117.4.
Definition in configuration.yaml :
client_id: !secret netatmo_client_id
client_secret: !secret netatmo_client_secret
Port forwarding is correct .

What can I still try ?

After the client_id and client_secret is added to your configuration.yaml you must enable Netatmo through the integrations page.

Menu: ConfigurationIntegrations .

Click on the + sign to add an integration and click on Netatmo . After completing the configuration flow, the Netatmo integration will be available.

I assume you did that step as well?

1 Like

Hi Jim,

I did that step; After clicking “Open website” the error appears.

I don’t have netatmo, but I assume you had to configure it on their website? It’s basically saying the endpoint you specified isn’t right in the oauth2. The fact that it’s replying a lan IP there seems a little concerning.

I know for google and alexa, I was forced to set up home assistant with both a valid certificate AND running on https port 443. Perhaps this is the same for netatmo?

I’m guessing you’re not using nabu casa? This sounds like a netatmo config problem where you set your oauth2 callback url. You might have to log into your netatmo account and see what you can find there. Are you using NGINX?

1 Like

Hi Jim,
You gave me a good hint!:
“The fact that it’s replying a lan IP there seems a little concerning.”
I replaced the internal address ( by the external address ( in Configuration >general and it worked !
PS: I am indeed using NGINX.
Thank you very much.