Netatmo not working on 2021.11.2 - unable to link account

After I upgraded my Docker container to 2021.11.2 from 2021.10.7, Netatmo failed to work straight away. It came up with a Reconfigure box in Integrations, but each time I try to link accounts, it gives the following error with the URL

It started happening last night, and 24 hours later it still won’t work. I have removed the Integration, restarted HA, and tried adding it back again with no luck. I’m now unable to add Netatmo back into HA.

I tried to obtain debug logs by using homeassistant.components.netatmo: debug within logger, but no logs are produced when I try to link accounts, probably because the integration hasn’t loaded at that point.

I’m using YAML mode and just have a Netamo internal and external thermometer.

Phew, it’s started working again. :slight_smile:

Not for me since two days.

For me neither. I updated from an ancient 2021.08.02 to 2021.11.3.
Anyone else had any luck?

Definately a problem here since upgrading from 2021.10.6 to 2021.11.3. Had to relink Netatmo and Home Assistant twice in two days now. Relinking needed a lot of retries until it worked again.

Same problem for me.
It seems trying an authorization in Nabu Casa, but I don’t have an account on it
I resolved (fo now …) reactivating Yaml configuration and reactivating Integration.
It asked me if activate Yaml or Gui config, selected Yaml and it pointed to right authorization (HomeAssistant application on Netatmo DevPage)

Couple of hours later and it linked successfully now. Hopefully the link doesn’t break. I have a lot of automations connected to these sensors.