Netatmo Presence stopped working

my netatmo presence camera integation stopped working some days ago.
i tried :

  • removing client_id and client_secret
  • generating a new api key in
  • reboot ha
  • add the new client_id and client_secret in configuration.yaml
  external_url : "" 

 client_id: 5f90xxx53b
 client_secret: nXxxxsIF
  • reboot ha
  • added netatmo integration
    but no camera detected :

and i get this error in log

Source: components/netatmo/
Integration: Camera (documentation, issues)
First occurred: 9:27:31 PM (1 occurrences)
Last logged: 9:27:31 PM

Error while setting up netatmo platform for camera
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/helpers/", line 193, in _async_setup_platform
    await asyncio.shield(task)
  File "/usr/src/homeassistant/homeassistant/components/netatmo/", line 94, in async_setup_entry
    async_add_entities(await get_entities(), True)
  File "/usr/src/homeassistant/homeassistant/components/netatmo/", line 53, in get_entities
    await data_handler.register_data_class(
  File "/usr/src/homeassistant/homeassistant/components/netatmo/", line 149, in register_data_class
    await self.async_fetch_data(
  File "/usr/src/homeassistant/homeassistant/components/netatmo/", line 117, in async_fetch_data[data_class_entry] = await self.hass.async_add_executor_job(
  File "/usr/local/lib/python3.8/concurrent/futures/", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/local/lib/python3.8/site-packages/pyatmo/", line 122, in __init__
  File "/usr/local/lib/python3.8/site-packages/pyatmo/", line 179, in update_camera_urls
    self.cameras[home_id][camera_id]["local_url"] = check_url(
  File "/usr/local/lib/python3.8/site-packages/pyatmo/", line 167, in check_url
    resp = self.auth.post_request(url=f"{url}/command/ping")
  File "/usr/local/lib/python3.8/site-packages/pyatmo/", line 170, in post_request
    f"{resp.status_code} - "
  File "/usr/local/lib/python3.8/site-packages/requests/", line 898, in json
    return complexjson.loads(self.text, **kwargs)
  File "/usr/local/lib/python3.8/site-packages/simplejson/", line 525, in loads
    return _default_decoder.decode(s)
  File "/usr/local/lib/python3.8/site-packages/simplejson/", line 370, in decode
    obj, end = self.raw_decode(s)
  File "/usr/local/lib/python3.8/site-packages/simplejson/", line 400, in raw_decode
    return self.scan_once(s, idx=_w(s, idx).end())
simplejson.errors.JSONDecodeError: Expecting value: line 1 column 1 (char 0)

What can i do more to get my camera on again ?

thanks for your feedback

Have you tried to power cycle the camera?

wow ā€¦ iā€™m so stupid.
the camera power cycle solved the problem ā€¦

1 Like

I had a problem with one of my Netatmo Presence(s) dropping out and it turned out that the SD card had bad sectors; so if this continues to reoccur, look at replacing the SD card.

1 Like