Netatmo valves disappeared and can't reauthorize netatmo integration

Hi. This morning my netatmo valves was unreachable, That occasionally happens, and a simple server restart solves the problem. But today it didn’t. I’ve tried few times to restart the server, and finally to reboot my raspberry, same issue.
So I tried to remove and reinstall the Netatmo integration, configure it via yaml (as the first time I did it), but I’m redirected to a page that reports:
“Missing code or state parameter in”.
I really don’t know what is happening, the Netatmo cloud status is OK,
Any suggestion? Thanks!

A fix will land in 2021.5.1

1 Like

Thank you very much!

1 Like

Thanks for the information - I had the same problem and 2021.5.1 worked except … there are no more battery stats for valves and control units … can you help a forum newbee how to figure out why? Or where to look? (If not, no offense taken! its just that I have no orientation where to ask /look: I had created a template sensor based on the battery_level property, which has magically disappered without replacment)

The fix for the battery issue should land in 2021.5.2. The battery level has been removed by Netatmo. I dropped them a message to check if that has been an intentional cleanup.

Thank you!

1 Like