Netflix on Chromecast incorrect state

I experience something weird. When I play a Netflix video on my chromecast the state correctly goes to ‘playing’ and my script A fires (trigger on state to: ‘playing’). When I pause the video from within the netflix app on my tablet, HASS still thinks the video is playing and my script B (state from: ‘playing’) does not fire… When I resume the video from within the netflix app (and this is the funny part) my script A triggers again.

So, although the state remains on ‘playing’, which explains script B not firing, why does script B fire when resuming the video?

Also, does anybody see a “paused” state for netflix video that was paused within the Netflix app (mobile or tablet)?
(sets the status to ‘paused’ and triggers the script)

I have the same problem. Only wile casting Netflix thoe.

Do you start Netflix from The script or by tv remote…? Please post your script…

I have the exact same problem. The state is correct if playing/pausing from the HASS webapp. Other android apps have no problems (youtube, etc).

Any news on this issue?

I set up Home Assistant last week using the latest docker imageand just ran into the exact same issue: Netflix/Chromecast “playing” is detected, while “paused” is not. So my script “lights off when Chromecast plays” works well, but “lights on when Chromecast stopped” is never executed. Not accepted by the wife…

HA logs when i start playing Netflix/CC from Web browser (as expected):
INFO (MainThread) [homeassistant.core] Bus:Handling <Event state_changed[L]: entity_id=media_player.living_room, old_state=<state media_player.living_room=paused; volume_level=1.0, is_volume_muted=False, media_content_id=, media_duration=2522, media_position=127.339, media_position_updated_at=2017-10-08T02:00:43.742724+02:00, app_id=CA5E8412, app_name=Netflix, friendly_name=Living Room, supported_features=21437 @ 2017-10-08T02:00:43.751816+02:00>, new_state=<state media_player.living_room=playing; volume_level=1.0, is_volume_muted=False, media_content_id=, media_duration=2522, media_position=127.339, media_position_updated_at=2017-10-08T02:03:56.341332+02:00, app_id=CA5E8412, app_name=Netflix, friendly_name=Living Room, supported_features=21437 @ 2017-10-08T02:03:56.346962+02:00>>

(notice “new_state=<state media_player.living_room=playing”)

Clicking "pause"
Empty logs.

I have found a workaround where “media_player.living_room=paused” is detected, but only when I pause Netflix/Chromecast by clicking the pause button in HA’s web ui. still not wife compatible, though.

Any thoughts on this issue?


Did some additional testing with other services; state “paused” is detected fine when streaming from YouTube, HBO Nordic and Plex.


I also get this behaviour on a new install of on Raspberry Pi 3. Plex and YouTube works fine, but pause/stop in Netflix is not detected.


Currently experiencing the exact same thing, and with Netflix only.
Do you guys thinks it’s a Netflix-app on the Chromecast bug? Or a bug in HA?

Just like to add that I am also experiencing this on HASS 0.58.1

Also 0.62.1 still netflix or (ruutu in finland) doesnt go to paused state at all.

Same in 0.69.1
For Viaplay it works, but not for Netflix.

This is the automation that I want to use to skip those “Are you still there?” screens on Netflix.

- alias: Chromecast auto unpause
    - platform: state
      to: 'paused'
    - condition: state
      entity_id: input_boolean.autoplay_chromecast
      state: 'on'
    - service: media_player.media_play

Just to add up the Numbers, I experience this behaviour too.

Even if you pause the chromecast through Home Assistant it instantly turnster back to playing.

I wonder if this is a Home Assistant issue or a Netflix issue.

Great idea, thanks! I’m gonna set this up for Plex, hopefully it will work with Netflix too in the future

I’m seeing this with the Emby app too, but not the youtube app.

I’m trying to create an automation to turn off my TV after x minutes of chromecast being paused, idle or stopped. This is kinda killing my plan because it will stay paused indefinitely