Netgear Integration no longer working

I finally updated from 2021.09.7 to 2021.11.5 over the weekend, and it broke my Netgear device tracker integration. Up until this version, I had it set up via the config file and it worked flawlessly, but after the update, the config file integration stopped working, and it asked me to set it up via the UI Integration panel, which I tried to do, but it can’t seem to set up.

I’ve got a Netgear Nighthawk X4S D7800 router, and I’ve tried setting it up with minimal options, as well as filling out all the fields, but nothing, see the error in attached screenshot.

The integration Docs say that my router uses port 80 instead of the default preset of 5000, so I tried that too, but then I get an additional error message:

I’ve had to revert to using NMAP tracking for now as pretty much all my automations that rely on presence have stopped working.



Same issue with my XR1000 on firmware, pretty sure it occurred during the november update and the december update hasn’t resolved it.

Same issue with my R6120.
Did you overcome the issue somehow?

I did the firmware update (v1.0.1.68) on the router and it started working.

Cannot add the integration and have done all that everyone else has done. I am using an Orbi RBR850 on firmware V4.6.3.16_2.0.51.

From a web browser, attempting to use the port 5000, I get a failure, however, using port 80, all is well. I also do not see the same integration panel, there is no “use ssl” checkbox.

Home assistant running the following:
Home Assistant OS 7.2


1 Like

Same issue here.
My target was to setup a device tracker using the netgear integration. Instead, I am using now the NMAP Tracker Integration. Works fine.