Network: External Access Disabled

@francisp does yours also say it is disabled under settings?

Yes it does. I think it is because I don’t have a Nabu Casa subscription.

Me neither… I had this all working great, then after upgrade I get this message… I cannot access HA from outside, but things like location updates work from mobile devices…

Having the same issue, can not access from outside, and Network indicates external access is disabled
Mine is a fresh install, HA running as a VM on ESXi.
port on my router is directed to my HA instance.
It is like the request never hits hits HA.
I have other VMs working the same way and they are all accessible from the outside.
need to try something like tcpdump on the server, but was hoping for a quick fix to this

I too show “External Access Disabled” under my “Network” header, but I am able still able to access from outside my network having entered my HTTPS URL in both the “Internet” and “Local Network” fields.

Running HA 2022.5.2 core in docker container, along side SWAG container for SSL management, connecting to DuckDNS.

Experiencing this as well. New VM install (haos_ova-8.0.rc4.qcow2 running on Unraid). Followed this post, then this one.

The remote https login page says “Logging in with Home Assistant Local”, takes my (correct) auth for my acct (which isn’t restricted to local network) then tries to load and fails. Initiates a 60s loop of waiting and retrying. Meanwhile, my homeassistant.local login reports:

Logger: homeassistant.components.http.ban
Source: components/http/ban.py:125
Integration: HTTP (documentation, issues)
First occurred: 00:41:19 (7 occurrences)
Last logged: 00:51:54

Login attempt or request with invalid authentication from <my device info>

There is no ip_bans.yaml in /config.

I am seeing “External access disabled” next to Network as well.

Had the same issue with the nginx reverse proxy, external access was unavailable out of nowhere (not after an update but at a random moment). Restarted the addon and external access was available again. After a complete restart, the network tab still shows external access disabled for some reason.

(Also running HAOS on pi4)

I’m having the same issues accessing my external URL since one of the recent updates. I’m using the Let’s Encrypt and Nginx Reverse Proxy add-ons within HA.

Home Assistant Core 2022.5.3
Home Assistant Supervisor 2022.05.1
Home Assistant OS 7.6
Running in VirtualBox from the official VDI

same problem here, HA in docker, and I’m using ssh tunnel via my VPS, pure IP addressing, no DNS stuff involved whatsoever

I’m not positive this resolved my issue (I haven’t backed out the change to confirm that it fails again), but I added the following to the homeassistant: section of my configuration.yaml:

homeassistant:
  external_url: "https://homeass.abc.net:8123" '

Note: you will need to change the homeass.abc.net to be whatever your actual DNS name is .

I then restarted my homeassistant server and now I can once again connect to HomeAssistant using the app on my phone and connected via 5G (i.e. the internet).

It still says “External Access Disabled” from the system screen:

image

It also says “Editor disabled because config stored in configuration.yaml” so I assume it’s using the change that I made:

image

I’ve attached some images… not sure if they worked.

I have same setup and same issue. I’ve restarted server several times with no luck. However, I’ve restarted the nginx add-on and now I can access from outside once again (still having the “external access disabled” text on network settings).

1 Like

Same for me, after restarting NGINX add-on started to work.

1 Like

My system is working again after the latest update.

I have the same issue here, I installed today and tried to setup SSL via pfsense and its refusing anything except homeassistant.local:8123

can confirm that with latest version AND reboot of host machine remote access works again

Still have the issue, I reinstalled twice on proxmox and once on a nuc I had laying around still disabled and still cant get it to accept a connection from anything other than homeassistant.local:8123. I tried both proxy managers and they both refuse to work. I tried both 8.0 and 7.6 nothing works…

After two weeks of trying to find a reason why things were no longer working, i changed my setup to get this to work

in configuration.yaml …

homeassistant:
  external_url: "https://xxxxx.duckdns.org" # note no port number
  internal_url: "http://192.168.0.2:8123" # internal ip address of my HA with port number

http:
   # ssl_certificate: /ssl/fullchain.pem
   # ssl_key: /ssl/privkey.pem
  use_x_forwarded_for: true
  trusted_proxies: # not sure i need this bit, but this is the network on which my nginx proxy sits
    - 10.10.0.0/16

my home router sends my traffic to a separate nginx proxy manager that i have running at home.

The nginx proxy manager in turn has a letsencrypt cert, with websockets enabled.
Traffic is forward from the nginix proxy manager to my internal homeassistant ip + port

The only addon i have on home assistant is duckdns. I dont use a separate letsencrypt or nginx plugin for HA

Amazing timing! Just as I loaded up the page to post I found a solution it seems you have beat me to it!
my configuration.yml reads as such

#Networking!
homeassistant:
  external_url: "https://homeassistant.yourdomain.whatever"
  internal_url: "http://homeassistant.yourdomain.whatever:8123"

#Possible fix for the damn external access!
http:
  server_port: 8123
  ssl_certificate: /ssl/cert.pem
  ssl_key: /ssl/key.pem
  #allowing Reverse Proxies!
  use_x_forwarded_for: true
  trusted_proxies:
    - 10.1.1.1
    - 10.1.1.155
  #disabling IP bans! Pfsense will handle this I don't need a local ban list.
ip_ban_enabled: false

I am not running Nginx reverse proxy OR Duckdns, I am just running straight DNS resolver with a host override for homeassistant in pfsense with a wildcard cert as well as a copy of the same cert locally, then portforwarding 8123, 80 and 443 in pfsense.

UPDATE I was able to go fully 443 by changing server_port: 443 and internal_url: to my fqnd without the port on the end.

1 Like

I am still unable to access HA outside of my network. I did everything you guys mentioned, but it did not solve anything for me.
Running on a Pi4, with DuckDNS and NGINX.
If anyone is finding out something other than what was already mentioned, please let me know!

Describe your setup: network environment, HA environment, versions, config, IP’s, ports, policies, services, outlining your network map, etc.
And then describe what you have seen so far, what exactly is not working, and which parts seem to work, logs, was it ever worked before, etc.
And then describe what you have tried.