Network failed after enabling LG TV

I’m running Home Assistant on docker (debian) on the host network.
It seemed to be working okay then I tried to add an LG Tv to the config.
I rebooted Home Assistant at which point it killed all my network on that host. I can’t ping it or access any services on it.

When physically at the machine I can get to the console and see docker is up and running.

I’m assuming it is trying to do something on the network or run a service that is conflicting with my host network and causing major borkage.

Any ideas what it is doing and how to resolve it?


What version HA you using?
Older version would not boot if config had problems recent version basically have a safe mode that it boots to when config bad

If you can ssh to host and fix config that’d be best

Run “nmap host_ip” from another linux pc. This will show ports and if HA running you can verify

Basically you need to determine why container not start and fix it. Since it not start after add lg I’d start there

Any chance the IP address of the server has changed? LG is working here.

Hi @tmjpugh I’m not sure and not sure how I can check from the command line, but it was a recent install . Maybe a week or two ago.

I can’t SSH to the host as all networking is down on the host. I can get to docker from the console and see that HA is running. This is what makes me think it is doing something on the network which is hijacking it somehow.

@DavidFW1960 the IP is defined statically on the host machine. I had a look at the server config already and it seems good. I’m assuming docker stops HA changing my host machine. this is what makes me think its something running in HA causing the issue.

I think what I might do is extract my config and try using the VHDX instead so it is better isolated. I’m hoping if I shutdown HA in docker networking will come back to life when I reboot.

If 2 week old install bad config likely not issue

I would still check host ip from console. Maybe it not on network at all.

@tmjpugh you were right …

On closer inspection it has played around with my IP settings despite them being defined statically.
I think its best to isolate this on its own VM. I cant understand how this happened out of the blue and I’ve got other things on this docker which I can’t afford to monkey around with. I probably need to better understand docker isolation too.


To be fair, @DavidFW1960 pointed it out first.

I don’t use docker host networking and map only the necessary ports. Might reduce the chance of docker messing with host network.

Nmap is a great tool
“nmap” from external pc on network would have quickly help identify your host changed IPs and the new IP. The xxx being the network you expect host to be in ( for example).

If not defined static in router it is possible for another device to be assigned the ip resulting in confusion.

I did think about that. I was trying to get discovery with mDNS / AVAHI working and it seemed host network was the only way to do that.

I will take a look at Nmap thanks. I have ARP Watch enabled but switched off notifications as I was migrating my network. I can now see in the logs when the IP changed. I guess HA decided it wanted to be DHCP for some reason and I haven’t assigned this MAC address I just put it outside the DHCP range.

I should probably create the reservations even though I don’t really need them and also check what other dockers I have with host access!