Network problem on raspberry pi 4

I have problems with a raspberry pi 4 4gb, I have installed home Assistant I have download from “ xz” I have tried with both “Balena Etcher” and “Raspberry pi imager v 1.7.3” but when I put it to my network I can’t access it. I have tried 2 cables and 2 routers. I also cannot see any IP addresses in my router for my raspberry with home assistant. If I instead install raspberry pi os 32bit and set it to my network, I can easily find my raspberry’s IP address.

Did the documentation have the network settings (support IPV4, IPV6, or both)? Did it have DHCP or Static with a preset IP address?

The link you provided, gives a 404 error for me. I am currently have mt github account up/open so …

The link comes from Raspberry Pi - Home Assistant

I see it hasn’t included .xz in the link.

Uses DHCP on the router linksys WRT3200ACM

Hallo Kasper
habe das selbe Problem - habe diverses Ausgetauscht und bekomme auch keine IP zugewiesen. :frowning:
Mein Pi4 an sich läuft, hatte zum versuch eine Raspberry Pi Image geflashed und da hat der Pi4 auch eine IP beim installieren gezogen. ( je für lan und wlan )

Gibt es schon eine Lösung ?

Hi, I’m also having this issue with Raspberry Pi 400. I also tried with Home Assistant 9.5, along with 9.4, but could not get the connection to work. Connection works just fine under Raspberry Pi OS so it is, seemingly, an issue with Home Assistant.

My setup includes Unifi Dream Machine and Unifi Switch but even when plugging into UDM I could not get internet to the device, nor from my main point of internet (i.e. where ethernet comes to my place).

Some commands and outputs.

From my another device.

% ping homeassistant.local
ping: cannot resolve homeassistant.local: Unknown host

Tried to login and run some commands on HA CLI.

% login
% nmcli con show
% nmcli
eth0 unavailable…

Seems to verify that there’s an issue with getting eth0 to come online.

Error: Can’t update config on eth0: Connection ‘Supervisor eth0’ is not available on device eth0 because device has no carrier

dmesg|grep eth0 only gives link is downand then numbers and renamed from...

nmcli connection up ifname eth0


Error: Can’t update config on eth0: Connection ‘Supervisor eth0’ is not available on device eth0 because device has no carrier

And these are from when the CLI is starting up.

A start job is running for wait Until Kernel Tine Synchronized (52s / 1min 30s)

Never finishes.

(FAILED] Failed to start Wait Until Kernel Time Synchronized.
See systemctl status systend-tine-walt-sync.service’ for details.
OK Reached target Systen Time Synchronized.
OK Started Discard unused blocks once a weck.
OK Reached target Timer Units.
Starting HassOS AppArmor…
OK Finished HassOS AppArnor.
Starting Docker Application Container Engine…

Minor update for those who are still having this issue. After some troubleshooting I managed to narrow down the issue being eth0 not having carrier which seems to translate to eth0 not loading drivers and as such, there’s no method to get it to connect to the internet nor locally. This is further validated by the fact that under Raspbian ethernet port works immediately where as Home Assistant it does not.

What you can however do is to try and use USB-A to Ethernet adapter and restart the RPi with that. This worked for me and I managed to get my RPi 400 online.

I’ve submitted a bug about this to Home Assistant’s GitHub, link below if anyone can add something to it so that this can get sorted.

Forgot to mention. I found this guide which could work for setting up Wi-Fi to Home Assistant. As far as I understand though using Wi-Fi is not recommended.

I mention this guide only to help get through the installation and hopefully enable the eth0 on RPi later but for one, I’ve yet to test this nor know can you re-enable eth0 after the initial setup is complete. And two, I’ll not be able to help you with any issues nor am I responsible if you break something or have other issues. Proceed with caution.

Hey Tomi, can you elaborate on the USB-A to Ethernet workaround?
I have the exactly the same issue - purchased a usb to ethernet adapter and placed it in a gigabit usb-a port. Flashed the SD card again with HA 10.5 but still nothing happens - can’t locate the RPi on the network. I tried also placing the adapter in one of the normal grey usb ports and also flashing with HA 9.4 from the link in this thread. Also I have the RPI 4 model B which is the same as RPi 400 from what I know.
The adapter’s green light is on and yellow flashing. The RPi red is always on and green from time to time a flash or two so from what I have read I am good on that part.
My skills in this area are near non-existent so I might be missing something obvious.

Hello @VasilShterev. Quite late on this, as I must’ve accidentally turned off notifications for replies… However the USB-A to Ethernet also stopped working so at the end of it I gave up, for now, running Home Assistant OS on RPi 400 natively, even with 2023 Dec update (I’not tested 2024 Jan update). I can however run Home Assistant with Docker under Raspbian OS and am currently testing the setup for future use with no issues, so far.