New Add-on: Cloudflare DynDNS

As I have my own Domains hosted at Cloudflare, I wanted to have the option to use my own DNS to connect to my Home Assistant instance using VPN.

For that I created a Cloudflare DynDNS Hassio Add-on, which updates the DNS with your current external IP.

The Add-on is avaible here:

1 Like

What is the difference with letsdnsocloud ?

I didn’t found that Add-on in my research, before starting creating my own, but after looking into letsdnsocloud, the goal of the Add-on is kind of different.

letsdnsocloud uses cloudflare and letsencrypt to make it possible to access your Home Assistant instance directly from outside. My goal was only to have a DNS which resolves to my Home external IP, so that I’m able to use VPN to connect to my Home Assistant instance. For that, you don’t need Letsencrypt.

On the other side, as small differences in the cloudflare implementation, this one supports the new API Tokens and ipv6.

1 Like

Thanks for the information.


It’s a miracle I stumbled upon this thread since my attempts to use letsdnsocloud failed due to bad response from CF, while your addon does work, which is cool. Still, it would be very nice to update several records for the same host, is it possible?

UPDATE: I’m terribly sorry for necroposting ahead of thinking: one doesn’t need to update several hosts, one has to setup CNAMEs on CF side and learn to think ahead of asking. Sorry once again.

1 Like

Hi! Thank you for the amazing Add-On! Just one question: Can you tell my why the Add-On keeps randomly set my proxied state to off?


proxies should always be ‘off’, as you want that the DNS Record is being resolved to your IP an not CF.

Is it changing on your installation randomly from ‘off’ to ‘on’ and back?

The goal of the Addon was to be able to have a Dynamic DNS to access your home IP, so that you can use it for VPN connection or so, that’s why using the Proxy function of CF doesn’t make sense.

But if you have another use case, I can extend the functionality to add the ability to configure the Proxied flag. I was generally trying to find some time to update the addon docker image to the new HA image.

Hmmm ok it only works if I have activated „with proxy“.

No it‘s randomly setting it to off and never back on.

The new flag would be perfect :pray:

My HomeAssistant uses both IPv6 and IPv4 at the same time. Using this Addon will default to updating the IPv4 to dns records, but I hope to use the IPv6 address. Can you add an option to specify IPv6 or IPv4? I looked at the code and it should be simple, you can specify the IPv6 address by using consensus.UseIPProtocol(6).