New Add-On: Cloudflared

Thank you. Great, I will check out the integration.

I have a DVR system for my CCTV cameras and I believe Cloudflare policy says you can’t use their service for streaming video. It would be nice though not having to enable VPN to check the cameras.

hello, I’m trying to use this system which seems more secure than duckdns, but I’m having problems already at the start :frowning:
the freenom site doesn’t work, so i can’t create a .tk domain
do you know if it’s a temporary down and just wait?
thank you
google translate

I have a problem with “additional hosts”. When I delete all entries in the field “Additional hosts” under the configuration tab and try to save the new configuration, then I get the following error message:

Failed to save add-on configuration, Invalid list for option 'additional_hosts' in Cloudflared (9074a9fa_cloudflared). Got {'additional_hosts': {}, 'external_hostname': 'xxxx.xx'}

Does anyone know what the problem is? I tried the additional hosts option but now I don’t want to use it anymore. Thanks!

First, thank you for the add-on, it’s awesome and simple, especially when dealing w/ cgnat. Questions, I have dual WAN set up as failover for my internet, will this still work when main WAN (registered IP in CF) fails and secondary WAN takes over?

I was able to set up HA to gain access via CF tunnel; however I’m not able to access my other services using additional hosts such as plex. Can’t seem to see anything wrong in CF logs but webpage is not found

Any help is greatly appreciated.

Yeah they might have problems or the service changed for good:

IMPORTANT NOTICE: Because of technical issues the Freenom application for new registrations is temporarily out-of-order.
Please accept our apologies for the inconvenience. We are working on a solution and hope to resume operations shortly.

So unfortunately my best advice (since I don’t know if the service is coming back) is to look at Namecheap or GoDaddy and buy a proper Domain name with all the benefits for a couple of $ / € a year to avoid the hassle…

How are you setting up the additional hosts? You can add any internal service via the add-on option “additional_hosts” and create a dedicated sudomain for them.
Regarding Plex: I am not sure if this will work since they forbid the use of excessive video streaming in their Terms of Use… (since all of the data would be processed via their reverse proxy, which is a lot of load for them).

yes, you have a to add an empty array for the option. See also this FAQ entry for this specific problem.

1 Like

Can you give me an example of an add-on you are using with the option “Open Web UI” and also let me know, what the URL looks like that you are being forwarded to?
My suggestion for those Add-Ons is always to create an additional_host with a dedicated subdomain, but this does obviously not enable you to use the button.

Nothing seems to work, config below


I assume this is just a copy / paste thing, but just to make sure, your YAML config should look like this:

  - hostname:
    service: http://10.0.19.x:5000
  - hostname:
    service: https://10.0.19.x:8006
  - hostname:
    service: https://10.0.19.x:32400
log_level: debug

If this is not the issue: Can you kindly open an issue with your add-on logs in GitHub so we can continue the discussion there? Also, please check in Cloudflare if the subdomains are created in the DNS settings.

ok I’ll open ticket in Github, thanks for quick response

1 Like

Hi and thanks for getting back to me. Appdaemon, tasmoadmin are just two examples. It’s trying to go whatever subdomain you point your instance to followed by the port number. So tasmoadmin would be for example. The problem is as I understand it, that in the subdomain in the tunnel, home assistant’s port (8123) is already included. So it’s trying to add a port after another port. I’m not that bothered as I’ve said as I can still access those addons but would be cool if there was a way to config that would address this. Thanks once more!

ok I just checked this, and you are right: The way the button is set-up is by using the current URL, removing the port and adding the specific add-on ports. This does work for an internal connection, but for any external connection you do have to open that specific port as well or create a separate subdomain (which will work but not using the button). Unfortunately, there is not much we can do in this add-on, so the workaround is just to define them as additional_hosts and use the subdomains if you want to connect to them externally. If you want to further pursue this, feel free to open a discussion in our Github Discussions. I am sure we can come up with a solution to suggest as a general HA UI improvement.

1 Like

I have the Cloudflared add-on up and running. It works great and I am very happy not to have ports exposed. I am having trouble getting the Google Assistant integration working. When i go to add Home Assistant in the Google Home app, I get an error message, cannot reach [test] - APP NAME.

Any suggestions?

So giving this some more thought, and the issues surrounding the redirection to the web browser from within the app.

Could we not just route the entire subnet? create a CIDR route, or even a static route for the exact HA host?..for all ports.

I use OpenVPN cloud which has been mint! Absolute transparency in terms of the way it works, I just have full network access, just as if I were on my LAN. This way I just set my external URL to the same as my internal URL, the private IP of my HA instance.

Something here is explicitly routing it to HTTP, maybe the domain setup? This would also solve issues like the post from the above user with other integrations not working. Full subnet access would be ideal.

Your thoughts.

Hi Tobias,

@brenner-tobias I saw in the newest release the mention that Freenom sites were being removed from Cloudflared add-on, does this mean that if you have your current sites through freenom that they’ll stop working or only newer sites trying to be added can not work with Cloudflare and thus removing this linkage? A little bit confused, because my sites are through them and even after upgrading appear to still be working fine, am I in trouble long-term?

Thank you,

I am actually not sure what is going on with Freenom. Multiple users have reported issues with domain names registered at Freenom and I could not move a newly registered domain name to Cloudflare. Therefore, I decided to remove the mention of Freenom in the Documentation. This is really everything we did: Change the documentation. So if everything is working for you, you don’t have to change anything and we will not be changing anything on our end. Having that said, I do fear that the free service might be removed or simply stop working at some point, so to be on the save side, you might want to look into purchasing a “proper” domain name from Namecheap or GoDaddy or any other reliable registrar sooner than later

1 Like

Before update to new release 2 days ago my .ml domain stop working but now after upgrade to new version its working once again, i dont know if you fix issue or problem fixes itself

Makes sense, and thank you for the heads-up!

Freenom does not provide new free domains. They say “temporary”, but you can not even do the extension of the existing at the moment.

But for the valid freenom free domains everything still works with Cloudflared without issue.

1 Like