[New Addon] Access machines in your homenet with Apache Guacamole, Ingress Support!

Tags: #<Tag:0x00007f326d205c50> #<Tag:0x00007f326d205b10>

Hi everyone,

I cobbled together this addon which some of you might find usefull.

Guacamole is a HTML5 webclient for RDP, VNC and SSH enabling you to remote into PCs or VMs with nothing but a webbrowser.

In the past i used a self contained docker image from oznu (https://github.com/oznu/docker-guacamole). Today i decided to try integrating that into Homeassistant. My Addon is basicly just that docker image with some very minor modifications to make it into a Homeassitant addon with Ingress support.

Since this is my very first attempt an making an addon for Homeassistant the integration is quiet basic. Namely no support for authentication through Homeassiant or something like that. and the only working platform is x64. (sorry raspberry pi users)

When first installing this addon Homeassiant might give an error message that installation failed. Just give it a few minutes it will pop up eventually. (I think this might be due to the size of the container)

The default login is “guacadmin” for both username and password.

2 Likes

This is a very handy addon, Thank you!

I have tested it with SSH and it works great.

Nice, is it possible to see what version of Guacamole is installed in the addon?

On the Guacamole login screen in the bottom right corner.
Right now its 1.2.0

I changed the url in the first post so that the addon has its own repository.
I also added support for installing it on a Raspberry Pi. Keep in mind that building the addon on a Raspberry Pi can take quiet a while.(close to 20 minutes on a PI 3B)

Link on addon broken:
Visit Guacamole page for details.
Instead pointing to Apache Guacamole it’s point to https://xxxxx.duckdns.org/null

heem how do I install it?

1 Like

Follow the instructions in the docs here to a non-official add-ons. Then put https://github.com/bleakvin/hass-guacamole of the repo as the URL to add.

1 Like

I have tested your Addon on the RPi 4 (8GB) with ARCH “aarch64” and it is not working, because it is only amd64 compatible…

I forked your Repo and fixed that :wink:
Now it is compatible with amd64, armhf, aarch64 and armv7…

I have only tested the aarch64 and this worked like a charm …
The other arch like armhf and armv7 need to be tested :crazy_face:

Here is my Addon Repo:

This works like a charm.
Currently only ingress works…any way to expose this on a port?

Under setting you can set a port to expose…

I used the „original“ addon from OP.

Your „fork“ did the trick. Cheers.

Thanks alot for creating this!