New auth system on Docker - not working for me


With the help from another thread I got the command working within a docker, but when I create a new user it says invalid Auth, even though I know the password and account are valid.

docker exec home-assistant python -m homeassistant --script auth --config /home/mark/HomeAssistant add user password

Any ideas please?


the --config <path> should be relative to the container. Try as docker exec home-assistant python -m homeassistant --script auth --config /config add user password

Or update it to match the mount point of the config directory in the container.

1 Like

thanks but that is exactly what I had… it is very odd

and when I do a list it shows the 2 users I created

so the list command shows the two users, but user authentication is not working?
Did you make changes to configuration.yaml to enable user auth? snippet of the changes you made?

1 Like
   - type: homeassistant
   # Uncomment next line if you want to enable legacy API password support
   - type: legacy_api_password

# Enable the auth component

Just these, I added the legacy one to see if that worked and it does.

I’m assuming the auth_providers: section is under the homeassistant: block, so this looks fine.
Dunno, enabled debugging logging and check the logs, maybe you’ll get some additional clues.

So does it ask you for the username and password or do you get 'password" field to enter only?

yeah it is under the right section and it does ask for a username and password, but just doesn’t accept them. frustrating :slight_smile:

anyone have any idea on this please? I’ve updated to 0.74 and it is the same. I cannot log in. I’ve tried to create users from inside the docker command line but it states

root@HomeAssistant:/usr/src/app# homeassistant --script auth --config /home/mark/HomeAssistant add Mark password1
bash: homeassistant: command not found

just me or is no one using the new system?

the command in bash is not going to be homeassistant. Should be something like

root@67f91015cce5:/usr/src/app# python -m homeassistant --script auth list

Total users: 0

thank you… that works and I can create a user inside the docker… but I still get invalid_auth grrrr

EDIT… I didn’t see you can now create a user in the GUI, but I had to enable legacy API to do that 1st!