Home Assistant Community

New Build iOS app just isn't working - error 400

#1

Hello

I have a new build of Hassio (2 days old) almost done nothing to it so far (91.2) I have installed the iOS app on my phone. 2 out of 3 components loaded and I got ticks :grinning: (Device tracker missing). I read a few posts about the “Device ID” being critical in its naming. So I retried with my name and adding an underscore - no go, tried with no spaces at all - no go. Deleted iOS.conf file and removed Hassio app and restarted but its still the same. Now nothing will load, the file “Known_devices” is never created and even if I add it manually it makes no difference. Also added iOS: to config.yaml

The one thing I have noticed is in the .ios.conf my “deviceId” has 2 spaces at the end inside the brackets. If I manually delete these / save & reboot they come back + I end up with an additional sensor for my phone battery and state on no 7 now :upside_down_face:

Should I start again with a fresh build before I get too deep, I was hoping this would be an out of the box easy add. I have had builds in the past and never had a problem with this before. I think my last build was 0.86 and was working just fine on the same iPhone.

My iOS.conf

{
    "devices": {
        "mattsiPhone  ": {
            "app": {
                "buildNumber": 34,
                "bundleIdentifer": "io.robbie.HomeAssistant",
                "versionNumber": "1.5.0"
            },
            "battery": {
                "level": 4,
                "state": "Unplugged"
            },
            "device": {
                "localizedModel": "iPhone",
                "model": "iPhone",
                "name": "Matthew's iPhone",
                "permanentID": "10EB0ABB-4D16-4E21-B21A-B7C3058ABF48",
                "systemName": "iOS",
                "systemVersion": "12.2",
                "type": "iPhone 8"
            },
            "deviceId": "mattsiPhone  ",
            "lastSeenAt": "2019-04-10T22:04:10.046810",
            "permissions": [
                "notifications",
                "location"
            ],
            "pushSounds": [],
            "pushToken": "This space intentionally left blank"
        }
    },
    "push": {}
}

Thanks All !

0 Likes

#2

Device ID is based on the actual name of the device, can you confirm you don’t have double spaces in Settings.app -> General -> About -> Name?

0 Likes

#3

Thank you for helping, I assume you mean my iphones name, I see no spaces, is there any difference because the names don’t match - matt v Matthew’s

0 Likes

#4

Very strange, I just joined your Beta testing @robbiet480 for 2.0 and everything works !. If I go back to the official release I now have all 3 ticks but still get error 400 “Location Failed to update”

Thanks

1 Like