New device type unknown

Being happy with my Neo Coolcam, I bought another one. But to my surprise this one is not recognized properly. Because of this I cannot configure configuration parameters. It’s displayed as “Shenzhen Neo Electronics Co Ltd Unknown: type=0200, id=1031”. I searched a bit and found that the type is listed here:
Then why is it not recognized? Could it be that it is added recently and do I need to refresh something first?

I have the regular z-wave (not the beta).

By now I’ve figured out how to set parameters using the set_config_parameter service.
That still doesn’t solve my problems though. The unit doesn’t send a “Sensor Binary Report” upon movement, which should probably be enabled throught the device config (which is missing).

I’ve also seen that others have added the device by downloading and manipulating the HA-version of manufacturer_specific.xml and further config. I’ve tried that, but so far to no avail. I’m also not fond of this type of customization, leading to all sorts of secondary problems in my experience.

So, would there be any other way to further customize the device? Is editing zwcfg*.xml my only other option? Would that persist over upgrades?