New devices discovered reminder

Is it possible to disable auto discovery of new devices completely?
I keep getting a reminder that new devices have been discovered and choosing cancel only helps unntil next restart.

Just delete or comment “discovery:” line in your configuration.yaml file

But first try this code. It solved the same issue for me due to UPnP components popping up at every restart.

discovery:
  ignore:
    - igd
1 Like

I never have enabled discovery and hashtagged “discovery” in config.yaml
If I just use ignore on one domain I guess all others are discovered?

That’s right

somenone has an answer to this?
Especially the reminder of the discovery of Google Cast would be nice to get rid of.
Dissabling zeroconf and ssdp in config.yaml does not help

1 Like

no one knows how to get rid of the “Google Cast” discovered reminder?
Discovery is not enabled in the config.yaml.

Having the same issue, discovery is not enabled yet I keep getting the alert. Very annoying.

I don’t know hot to get rid of the “Google Cast” discovered reminder?

There’s an issue about it on github, it’s been doing it since 0.95 apparently:

I hadn´t seen the issue on github.

Someone knows how to solve this issue. I still have the problem with 0.100.2

search for ‘discovery’ on the issues for homeassistant and you should find something.

Thanks for the hint.

Found and use this for now until it gets solved:

  - alias: 'Remove new devices notification'
    trigger:
      - platform: state
        entity_id: persistent_notification.config_entry_discovery
        to: notifying
      - platform: homeassistant
        event: start
    action:
      - service: persistent_notification.dismiss
        data:
          notification_id: config_entry_discovery