New devices won't pair. Old Devices word re-pair. What's going on?

I’m new to ZHA, recently switched over from z2mqtt. Things aren’t going very well. Initially I was able to pair about 15 Aqaua sensors and a few IKEA remotes and outlets (never more than 20 devices). After a short while, 8 of the Aqara sensors dropped off the network. I tried clicking their buttons and bringing them in close to the coordinator (CC2531 latest Z-stack firmware), and replacing batteries, but they won’t rejoin. I also manually removed a couple of devices and tried to re-pair them but they refuse. Am I just doing this wrong?

Just now I tried to add a freshly updated IKEA bulb that has never been on the network and I got a message about the interview started but it never made it any further and now the bulb has done nothing on about a dozen subsequent tries to repair it.

The worst part: nothing is showing up in the logs. Any ideas on where to start?
PS: I do have a new CC26xx coordinator coming but I never had this issue with the 2531 on z2mqtt.

EDIT: I got one Aqara Temp sensor to rejoin but it still shows up as Unavailable for all its entities.

Reconfiguring node with ieee_address: 00:15:8d:00:02:d7:f2:58

[0xD5C6]( started configuration

[0xD5C6:ZDO]( 'async_configure' stage succeeded

[0xD5C6:1:0x0000]: skipping channel configuration

[0xD5C6:1:0x0405]: skipping channel configuration

[0xD5C6:1:0x0001]: skipping channel configuration

[0xD5C6:1:0x0403]: skipping channel configuration

[0xD5C6:1:0x0402]: skipping channel configuration

[0xD5C6:1:0x0000]: 'async_configure' stage succeeded

[0xD5C6:1:0x0405]: 'async_configure' stage succeeded

[0xD5C6:1:0x0001]: 'async_configure' stage succeeded

[0xD5C6:1:0x0403]: 'async_configure' stage succeeded

[0xD5C6:1:0x0402]: 'async_configure' stage succeeded

[0xD5C6]( completed configuration

[0xD5C6]( stored in registry: ZhaDeviceEntry(name='LUMI', ieee='00:15:8d:00:02:d7:f2:58', last_seen=1638752221.5778415)

General tip is to first start by adding mains-powered devices acting as “Zigbee Router” (a.k.a. repeater):

Battery-operated Zigbee devices like wireless sensors and remotes, as well as many mains-powered Zigbee lightbulbs, are not Zigbee routers as they are not permanently powered by mains-power there is no guarantee that they will always be online to route (repeat) messages within the Zigbee network.

Thanks for the tip. Unfortunately I am unable to add anything, wired or wireless, at this time. Seems like a bug somewhere.

Did you just update update HA? Im having similar type issues with losing all my zigbee devices after update

Yes, I went from 2021.11 to .12 when it came out.

Yah. I did too and I lost all my battery powered Zigbee devices. Although I was able to re-pair