New DSMR reader components floods HA

I turned on the new DSMR reader component. This component seems to flood my system. Mqtt messages are processed and mapped on a lot of sensors high frequently.

This component must be optimized to make it useful. Optimizations;

  • Select only the sensors that you need
  • Configure the frequency/interval for update

Currently I turned this component off because HA became quite unresponsive after I turned it on.

+1. I only enabled MQTT in DSMR-reader software to transmit 4 data fields, however the new DSMR-component (103 release) creates sensors for all possible data fields from DSMR-reader.
Feels like this component needs to be optimized indeed. @Marsman did you create a bug/improvement report in Github already? Thanks for the initial work though, @depl0y!

It is dsmr-reader who publishes to this component, so the component is fine. You can change the interval in the admin
admin/dsmr_mqtt/mqttbrokersettings/ and then at the bottom “MQTT proces sleep”

I had the same problem used to use custom mqtt sensors in HA to receive specific topics, this worked stable. Switched to this component and after half a day HA does no longer update the sensors only restarting Mosquito add-in gets it processing again in HA.
Swithced back to custom mqtt sensors again, no issues so kept it this way, but still prefer a standard component (when that would work stable)

For me this works stable now for a long time. The flooding was solved with a DSMR release in which the MQTT process sleep configuration was added.

hi all,

I’m kinda new to mqtt and home assitant (OS) i’ trying to migrate from my Athom Homey to HA.
I wanted to get some services working before switch all my zwave and zigbee clients.

Currently I’m strugling to get mqtt broker working with DSMR-reader
my setup:
windows server 2012 with Hyper-V instance of HA (via the official install method) core v0.113, OS v4.11.
raspberry Pi 4 with dmsr-reader docker (xirixiz/dsmr-reader-docker) (3.1.1)
my steps:

  1. Installed mosqitto broker add-on on HA supervisor
  2. Created a mqtt user and password (mqtt_user)
  3. Configured via mosquito intergration
  4. installed dsmr-reader integration
  5. Configured mqtt broker host (HA ip), user and pass, ssl disabled
  6. Enabled mqtt topics in DSMR-reader (split topic)

a bunch of entities are created by the addin but no data is received.
When I check the DSMR-reader status it says 200msg are queed

Where to start debugging? I can’t get dmsr-reader to generate logs, and i can’t get HA to generate mqtt logs (or do’n know where to find them)