New Duck DNS 1.12.5 - Got Problems

Hi guys!

Anyone else have this problem too? After I have updated to the new 1.12.5 version of Duck DNS, I can’t update the configuration. Even if I don’t change nothing, but just want to save it… I get an error like…

Failed to save addon configuration, not a valid value for dictionary value @ data[‘options’]. Got {‘lets_encrypt’: {‘accept_terms’: True, ‘certfile’: ‘fullchain.pem’, ‘keyfile’: ‘privkey.pem’}, ‘token’: ‘xxxxxxxxxxxxxx’, ‘domains’: [‘’, ‘’], ‘aliases’: [], ‘seconds’: 300}

Any resolution in order to solve this issue? I have changed my token and I can’t update it…

Thanks in advance

I had a similar issue - I noticed the bug report in the previous version so tried removing domains and aliases so there was a single duckdns domain, This seemed to fix it for me and allowed it to renew my certificate and get everything running again.

Wow, yes… it is working but it is stupid :frowning:

Agreed, glad it worked for you too though.

This solution allows to restart the duckdns add-on service but not to make everything work again as before, with the correct alias/es.
So you want to tell me that no one knows what has changed and how to correct and save the configuration file to restore correct operation with aliases?

After several attempts and comparison with the documentation, in my case I just had to delete the specification of what’s the alias as an entry in the domains list:

  accept_terms: true
  certfile: fullchain.pem
  keyfile: privkey.pem
token: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
  -            <-removed
  - domain:
seconds: 300

You are the man! Thank you! It is working for me too. I was using an older version of duckdns :smiley:

anyone knows how to add 2 aliasses?
It used to work with the previous version of the addon, but not anymore with the latest one.

  - domain:
  - domain:

doesn’t work… (tried al kinds of syntax… no go…)