New entities / Z-wave nodes not showing in HA through Fibaro integration

Tags: #<Tag:0x00007f73937661b0> #<Tag:0x00007f7393766020>

I use the Fibaro integration with a Fibaro HCL to get my Z-wave units in HA. This has worked smoothly until I decided to add some more Z-wave units. It works fine directly with Fibaro, but they do not show up in HA. I have tried restarting, updating and also disabling/enabling the Fibaro integeration by commenting out the relevant lines in configuration.yaml

How can I tell HA to update the list of entities from Fibaro HCL?

My configuration for the integration:

fibaro:
   gateways:
    - url: http://192.168.0.xx/api/
      username: user
      password: pass
1 Like

Same issue here.
Since no answers, I guess the only thing left is to go through the code and check what Fibaro integration does…
I’d guess HA cached some configuration file locally, which needs to be refreshed - deleted.

Looking at the code it does fetch new devices directly from Fibaro on each HA startup, so no local caching.
In my case the issue was Fibaro HC privileges: in HC go to Configuration -> Access Control, and add access to new devices for your HA user.