New entity NodeRed error

I can no longer add new entities, I don’t see it in the sensor “Entity congif” menu, what happens?
I had never seen “none”

Hit the + button to add a config.


I have already tried it, it doesn’t work, the screen to create a new entity appears,

but then it is automatically overwritten on an already existing one
or repeats “none”

You have that config set as a binary


It will not show up in a sensor node

If you drag out a binary node, you should see that config in the list.

I don’t understand, I’ve been using nodered for years, I know it, but maybe the new version is different, I can’t add a new device, can you? how do you do?

Try this go to the sensor node click the + to add a config. Give the config a name in the name space.


Click the add button. Then where the debug is choose the config tab.


In the list under ha-entity-config, you should see the new node in the bottom of that list.


maybe you’re wrong, as you say it creates a “ha-device-config” (test) for me, I have to add a “ha-entity-config” with “1” next to it, I have 100 more like this.


You lost me here. The 1 shows that 1 node is using that config. Give the new config a unique name, add it, look at the last node in that list, is it not there?


I think you’re just looking for likes, without knowing.
I’m waiting for other users, bye

ok good luck with that.

I reverted to the old version 17.0.13 (nodered 3).
With version 18 (nodered 4) I didn’t understand how to do it.

The issue here is two-fold.

1 When you add a new sensor after this update it defaults to adding an already configured entity, which if you are not careful you will overwrite, like I did.

2 You now have to click the ‘+’ button to add a NEW entity.

3 It defaults automatically to setting a BINARY SENSOR, so you now MUST select SENSOR from the drop down list, otherwise you will overwrite the binary sensor in the id list.

4 If you add your entity in this way you will succeed. I am sure this was not supposed to happen, but if it is not a bug then you CANNOT add a new Binary Sensor.

So this is a very flawed process now after the update

I can create new binarys and new sensors without issue. I added 6 new configs 3 binary and 3 sensor.


Now inside a sensor node, I can only see the sensor configs in the dropdown


Inside a binary node I can see only binary configs in the dropdown.


The dropdowns will only show configs that can be used for it’s respective type but hitting the + will allow you to make a config of any type rather than limiting you to just the config type of the node you are working in.


7/7/2024 release 4.0.1 NodeRedCompanion solved.